Target compilation issue in OAT 2.0


#1

Hello!

I am trying to work with Q2686 + OAT 2.0 Release downloaded from Wavecome.
I started with Hello_Word sample. It works in RTE (Debugging) mode perfect but when I compile it in Target mode I have problem:

  1. as i inderstood - I can’t download dwl in module - after downloading the AT+WOPEN=2 command shows what no any code downloaded; But standart binary dwl compilled by Wavecom and included in SDK works OK.

I tryied to compile that COPY of the sample (not createtd on other PC) an other computers and have two types of results:

  1. gcc_Hello_World_256KB.dwl - size 74016 - Works OK
  2. gcc_Hello_World_256KB.dwl - size 74560 - Didn’t work

All computers works in intranet under WinXP with lastest updates. Compile process isn’t depend on CPU types (intel or no, Core duo, etc.)

How to force OAT works right on all computers?

Best regards.


#2

Are you sure you used “Rebuild-All” after copying project folder to another computer? I had similar case till I used Rebuild-All and there were no more problems.


#3

Hi, jacfry!

I tried Build, Clean+Build, Rebuild, Clean+Rebuild one by one and in combination without any positive effect :frowning:
I tried re-install OAT without any positive effect :frowning:
I think: is there any specific compilation settings that i can check?