[SOLVED] WIPFILE filename being cut off

Hello, I am writing to an FTP server with the following command using a terminal and AT commands. If I write to the root of the server, the file is sent successfully. If I send the file to a path, the file will be created but part of the filename and the extension will be cut off. What could be causing this? I am new to this so it may be something quite simple that I am missing.

My command (with folders and name changed): The actual filepath is 65 characters long.

The result is a file FILE_AA_BBB_CCCC_D_1311202 with no extension in the correct folder.

I tested but cannot reproduce the issue using Wipsoft v5.43 with FileZilla server 0.9.

The file was created with extension correctly.
Do you have chance to check whether it is server problem?

I have not tried on another server yet, but I will. It seems that I am also running older software. The software version I am running is:

WIP Soft v541 on Open AT OS v635
Jan 28 2011 09:29:52 WIPlib:v5a35 WIPSoft:v3b25

I will try to do an update and try again.

I have updated my firmware and libraries to the latest, and it has resolved the problems.