[SOLVED] impossible to serial connect


#1

Hello everyone,
I’m using a FXT009 modem and I’m having trouble with the serial interface. I’ve tried a null modem cable, a 5-wire cable (using cts and dts) and a full 9-wire cable. I’ve check the wiring map several times and made sure it matched my home-made cable.
I’ve tried connection to the modem with hyperterminal at different speeds and flow control config (not only default 115200).
All those connection where made without any program running and I got no answer to at commands. I also tried the tutorial flow control code examples in case it had something to do with at mode and data mode activations but the serial port would not work neither.
Connection using developer studio is also impossible. I’ve tried the autobandig with and without flow control and the port will not open or, more appropiately it opens but with an “it won’t work” error message:

Open and load local port COM1 => ERROR: Time out: 20000ms
Open and load physical port COM1 => ERROR: Time out: 20000ms
Open port COM1 => DONE: Port opened
Open port COM1 => DONE: Port opened
Load informations from target => ERROR: Time out: 20000ms

So if there is anything you think I did wrong (or just didn’t do at all) I would be gratefull if you share with me. If you don’t know, thanks anyway for your time reading this.

by the way, USB connection works fine.


#2

I’m at the point of having doubts with everything I thought right so please someone confirm my wire connections are ok:




Thanks


#3

I solved the problem so just in case someone ends up here in the future:

It must have been some kind of problem with my computer serial port (which is strange as I had tried with another computer without results).

Anyway I used a usb-serial converter. As the converter crosses Tx and Rx I had to ad yet another intermediate cable to cross them back for connecting with my db15 to db9 cable. It worked at first try.

Thanks anyway for reading


#4

Thanks for sharing with us :slight_smile:

.Thibault.