SMS Message CMS ERROR 350

I am trying to send the SMS message using AT Command in MC7354 card:

AT+CMGS=“phone number”

It always gives me


I cannot find error code 350 so I am wondering what this error code means.

Note: it only happens for me for Telus carrier, Rogers and Bells are working fine.


Just out of interest, have you set the correct SMSC (SMS Message Service Center) phone number for your sim/carrier?

ciao, Dave

Yes, I use exactly the same AT command sending to Rogers/Bell/Telus MC7354 cards; Rogers and Bell are working perfect but Telus one always gives me CMS ERROR 350, even I change different Telus sim cards…only Telus carrier


I think you’ve mis-understood my question.

Each operator has their own SMSC phone number - which is different for each operator.

I think that you can use AT+CSCA get/set the SMSC, and I think it would be worthwhile checking if this number has been set correctly inside your Telus card/SIM.

As I understand, the SMSC is set inside the SIM card by the carrier as part of the SIM provisioning process.

There’s a bit of info around the internet (mostly to do with android and sms issues) that describes what the SMSC numbers are for various operators.

ciao, Dave


I check the SMSC number using AT+CASA for Telus card:

+CSCA: “+16475800172”,145


It looks ok because that number is from Telus short message service centre. Could you tell me what does the +CMS ERROR CODE:350 mean?

Thank you


I’m out of ideas.

+CMS ERROR 360 doesn’t seem to be in the GSM spec.

Time to contact your distributor directly.

ciao, Dave

I am seeing the same error on SMS send on the Sierra MC7304 (SWI9X15E_04.05.23.0) on Vivo in Brasil. Other carriers work fine. We are using PDU mode (AT+CMGF=0) and SMSC is correct.

Did anyone get any information on why the module is outputting CMS ERROR 350?


I have found a fix for this issue in my case. It was related to the SMSCA.

The SMSCA read from the SIM was:
Send: AT+CSCA?\r
Rcvd: +CSCA: “+550101102010”,145\r

I changed it with this command:
Send: AT+CSCA=“550101102010”\r
Rcvd: OK\r

Now I no longer see the CMS ERROR 350 error and SMS messages are delivered successfully. So it may be as simple as removing the leading ‘+’ from the SMSCA?

It’s worth noting that +CSCA has an optional second parameter which I left blank. According to TS 27.005 the default is typically 145, but in this case the module used 129 because I did not specify a ‘+’ as the first character.

Send: AT+CSCA?\r
Rcvd: +CSCA: “550101102010”,129\r

To find this issue we captured over the air messaging and found that the module was sending the SMS to the network and initially got an ack, but the network was later rejecting it via SMS submit report. The Failure cause listed was 195 (0xC3). I referenced 3GPP SMS spec TS 23.040 and found the failure cause mapped to “Invalid SME address”.

A closer look at the outgoing SMS PDU the module was sending to the network showed that the MC7304 was adding extra '0’s to the end of the SMSCA in the Dest addr field.

Hope this helps someone,
Casey Elder

Thanks Casey, good catch!

Indeed, could be a known issue fixed in FW version > 5.5.22.x.
Please upgrading to FW > 5.5.22.x to solve the issue.
But if FW upgrade is not possible, you may try removing the “+” sign on SMSC (+CSCA) to workaround the problem.


Did anyone ever get an answer to the question of what +CMS ERROR 360 actually means :question: