Slow for MC7455 to register in Windows 10 network upon dial-up

We are using a MC7455 to replace an existing mobile/modem adapter in a Windows 10 system, that connects to mobile network via dial-up. With the old mobile/modem adapter in the users application they capture data, press the transmit button, dial-up connects to mobile network, transfers data, drops the line. All works fine, operation completes in seconds, users happy.

However with the MC7455 installed in Windows 10 with latest drivers, the dial-up it takes, about 30 seconds (or more) pausing at the “Registering your computer on the network” Windows pop-up box. Once complete and Windows has IP address, works fine, data transfer rate is fine, Windows works fine etc. I can see the delay in the log file "ModemLog_Sierra Wireless Snapdragon…txt file as well.

I have repeated this with a clean Windows 10 installation and latest Sierra drivers. Once connected, after waiting 30 seconds odd, connection is fine, signal strength fine, absolutely no connection/speed issues, just takes inordinately long to connect and register network the first time.

We are not using the cellular always on connection.

Any thoughts how to stop this taking so long to connect ?

are you using latest FW?
Is the signal good?

do you see problem in Linux?

Not tried Linux.

Only Windows 10.

Any Linux distribution recommended, though I need it working in Windows 10.

You can try ubuntu 18

Managed to install Ubunto desktop, which happened to have a USB installation stick handy. It sees the Sierra card and can offer to setup mobile network.

However I am unsure how to install the Sierra Linux drivers to get “serial” ports to appear as a modem, to be similar to my Windows 10 installation.

You need to install mbpl usb driver MBPL_Drivers_R24_ENG3-src.tar

You can also see this topic on the mbpl installation

Well I have tried, did not manage to get the MBPL drivers installed in Ubunto, all the documentation points to download drivers here, but not detailed installation instructions.

Did connect via minicom to ttyUSB2 and can get AT commands and responses.

Not sure how to add dial up networking to Ubunto, most internet instructions I found use programs not available for Ubunto.

In the end I need to get this working with Windows, so not to sure what getting working with Ubunto will achieve.

I believe the MC7455 I have have been modified for USB2 connection only.

So back to Windows tomorrow…

Well got someone else to finally install the drivers into Linux and create a dial up connection and surprise surprise takes about 30s to connect. No different than Windows.

So back to Windows, bit of log file investigation and found is asking for an IPV6 DHCP address and timing out as IPV6 clearly not supported. Unbinding IPV6 from the dial up connection and connects instantly.

Result, once one knew where to look.