[SL8090 under Linux] - problem with ttyUSBx interfaces


#1

Hi,

I have faced some strange problem with the modem. At the beginning I configured SL8090 under linux using pppd and
it worked ok (at least 4 usb_serial devs were seen). Lately I have noticed that my modem is showing only one - ttyUSB0.
it means that bNumInterfaces = 1. At this point I do not really know where the problem can occur and why is there only one
usb_serial device ? I do not have a chance to check the modem under different system or try different modem because it is placed on the custom board.

Does anyone know how the modem works when W_DISBALE line is active? How many interfaces is given in such situation?

BR,
Karol


#2

Hi Karol,

Did you check the PID? Are there any issues with that? Try to install the drivers again and test once. If you still face issue please provide the Syslogs from the beginning.

Regards,
Rex


#3

Hi,

I do not think that can be something with pid.

Here are kernel logs: kernel.log (26.4 KB)

I will try to check this on another board.


#4

I checked it on another board - and it works properly - 5 ttyUSB devs are created so it seems to be some kind of hardware/firmware issue on the modem but I’m not able do diagnose it and I don’t want to lose this device.

SL8090 creates devices with minor nr from 0 to 5. What is the destination of each device - I suppose that some of them are for AT commands channel purpose. Which one can be used for SierraDMLog ?

How the device will act when W_DISBALE line is in its active state - the serial devices stay unchanged ?


#5

I think that my modem is in some kind bootloader mode - is it possible?

How can I check this ?


#6

Hi,

I had some hardware problems with modem reset line so it worked faulty. Its behaviour was strange because in case of one device one ttyUSB dev was created and another one did not show any sign of life.

BR,
Carl