SL808X ring issues

Hi all,

I’m now testing the ring tone on the SL808X. I found both the AT command and ADL do not support audio for this module. When receiving the incoming call, I could only see a “wake up” signal on WAKE_N. That’s it. Is there anyone having the experience with the audio on SL808X?

Appreciate your attention!

I tested on SL8080T and when an incoming call comes, i can see the ring indication. FW used is 7.52.2.A5

What exact issue are you facing? which FW version are you using at your end?
are you using 8-wire UART?


I tried both FW 7.52 and FW7.53. I can see the ring indicator signal changes which is like an enable signal. I want an analog signal run on the SPK pin when there is incoming call. I’m not using 8-wire UART, just using the default settings (I think it’s 4-wire UART).


Just a quick thought:

Are you using the correct ‘Bearer’ for your incoming call? Modems and Telcos treat Voice and CSD (Circuit Switched Data - as opposed to GPRS data) calls differently.

I’ve been tripped up this way in the past.

I’d start by having a look at AT+WRIM (Ring indicator mode) and maybe AT+CBST to see if they’re applicable to your module.

ciao, Dave


I’m using this configuration: “at+cbst=0,0,1” which means “autobauding, modem type: none (default value)”, “no data compression is provided and only asynchronous mode is supported (default value)” and “non transparent only (default value)”.

After configuring “at+wrim=1,71,100”, I can see the ring indication pulse from the “WAKE_N” pin. However, ring indication is not what I need. I want a continuous analog signal showing up in the SPK pin or some another pins which can make the ringer ring when the call incomes.

I tried both on FW7.52 and FW7.53, I can’t hear the ringing sound when there’s incoming call. I scoped the signal on SPK pin as well, and didn’t see any usable signal.

Then, I tried to use “adl_tonePlay” to play a tone on the speaker, I got nothing on the speaker. (tried both on FW7.52 and FW7.53).

These are all I got. I’m wondering if I need to configure something else or I did something wrong?


In general, the audible ring signal is not “in-band”; ie, it is not sent as audio in the comms channel by the network - so the terminal has to generate it itself.

If you were doing this with a “dumb” modem, that would mean that your Host application would sense the RI signal (or +CRING or whatever), and use that to start doing its own alerting …

So, if you have an external host with the capability, you could also do it that way.

From Open-AT, adl_tonePlay() or similar would be the way to go.

Need more detail of what, exactly, you tried.

Have you managed to get adl_tonePlay() to work at all in a simple, standalone application - such as one of the Dev Studio examples :question:
If not, that’s the place to start …


Thanks for your attention!
I tried a very simple application that I want to play a 300Hz tone on the speaker every 400ms. Following is the code:

#include "adl_global.h"
#include "generated.h"
#include "adl_audio.h"
#include "adl_TimerHandler.h"

s32 handle;

void MyAudioEventHandler ( s32 audioHandle, adl_audioEvents_e Event )
switch ( Event)
case ADL_AUDIO_EVENT_NORMAL_STOP://ADL_AUDIO_EVENT_NORMAL_STOP is sent to the owner resource when a tone is stopped automatically at the end of the duration time.
TRACE (( 1, " Audio handle %d: stop ", audioHandle ));
// unsubscribe to the speaker
//adl_audioUnsubscribe ( handle );
case ADL_AUDIO_EVENT_RESOURCE_RELEASED://automatically unsubscribed due to a prioritary use
default: break;

void Timerhdl(u8 ID, void *Context){
	 TRACE (( 1, "inside Timer handler" ));
	adl_audioTonePlay( handle, 300, -10, 0, 0, 50 );
void main_task(void) {
	handle = adl_audioSubscribe ( ADL_AUDIO_SPEAKER, MyAudioEventHandler,
	adl_tmrSubscribe( TRUE, 4, ADL_TMR_TYPE_100MS, Timerhdl );

But I still could not get any sound from the speaker. (tested on FW7.53 and FW7.52).