Sierra Wireless 313U + Ubuntu 14.04 issue. Help!

Hello Forum,

I am having issues using an AirCard 313U and Ubuntu 14.04. If someone could review my steps below and provide some guidance it would be be super helpful. Thanks!

I recently purchased a USB LTE modem from Embedded Works along with an AT&T data plan, and I have attempted to follow the directions to get the device to work via PPP from here: [ ... -ip-modems](

When I plug the device into the computer, I can see the device when I run the lsusb from a terminal window.

Bus 002 Device 006: ID 1199:68a3 Sierra Wireless, Inc. MC8700 Modem

When I look for the modem as a network adapter via ifconfig -a I see is listed as wwan0

wwan0     Link encap:Ethernet  HWaddr f6:ef:da:59:01:07  
          BROADCAST NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

And when I execute modprobe sierra and modprobe sierra-net I see driver info.

chris@chris-Latitude-E6520:~$ modinfo sierra
filename:       /lib/modules/3.13.0-66-generic/kernel/drivers/usb/serial/sierra.ko
license:        GPL
description:    USB Driver for Sierra Wireless USB modems
author:         Kevin Lloyd, Elina Pasheva, Matthew Safar, Rory Filer
srcversion:     D4556400FB61AEA3D07DCEC
alias:          usb:v0F3Dp68A3d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v0F3Dp68AAd*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v1199p68ABd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p68AAd*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v1199p68A3d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v1199p6893d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6892d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v1199p6891d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v1199p6890d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v1199p6880d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v1199p685Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6859d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6856d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6855d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6853d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6852d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6851d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6850d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p683Ed*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p683Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p683Cd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p683Bd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p683Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6839d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6838d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6835d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6834d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6833d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6832d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6822d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6821d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6820d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6816d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6815d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6813d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6812d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6809d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6808d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6805d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6804d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6803d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p6802d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0029d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0028d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0027d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0026d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0025d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v1199p0023d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v1199p0301d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0120d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0112d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0021d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0019d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0224d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0024d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0022d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0220d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0020d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0218d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0018d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1199p0017d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v03F0p1E1Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v03F0p211Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v03F0p1B1Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0F3Dp0112d*dc*dsc*dp*ic*isc*ip*in*
depends:        usbserial
intree:         Y
vermagic:       3.13.0-66-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        1C:A1:9C:B2:D4:52:43:6B:0D:71:F1:84:5E:5C:DC:5A:D4:4A:7D:B8
sig_hashalgo:   sha512
parm:           nmea:NMEA streaming (bool)
chris@chris-Latitude-E6520:~$ modinfo sierra-net
filename:       /lib/modules/3.13.0-66-generic/kernel/drivers/net/usb/sierra_net.ko
license:        GPL
version:        v.2.0
description:    USB-to-WWAN Driver for Sierra Wireless modems
author:         Paxton Smith, Matthew Safar, Rory Filer
srcversion:     896313DAA9C61C842F37412
alias:          usb:v0F3Dp68AAd*dc*dsc*dp*ic*isc*ip*in0B*
alias:          usb:v0F3Dp68AAd*dc*dsc*dp*ic*isc*ip*in0A*
alias:          usb:v0F3Dp68AAd*dc*dsc*dp*ic*isc*ip*in07*
alias:          usb:v1199p68AAd*dc*dsc*dp*ic*isc*ip*in0B*
alias:          usb:v1199p68AAd*dc*dsc*dp*ic*isc*ip*in0A*
alias:          usb:v1199p68AAd*dc*dsc*dp*ic*isc*ip*in07*
alias:          usb:v0F3Dp68A3d*dc*dsc*dp*ic*isc*ip*in0B*
alias:          usb:v0F3Dp68A3d*dc*dsc*dp*ic*isc*ip*in0A*
alias:          usb:v0F3Dp68A3d*dc*dsc*dp*ic*isc*ip*in07*
alias:          usb:v1199p68A3d*dc*dsc*dp*ic*isc*ip*in0B*
alias:          usb:v1199p68A3d*dc*dsc*dp*ic*isc*ip*in0A*
alias:          usb:v1199p68A3d*dc*dsc*dp*ic*isc*ip*in07*
depends:        usbnet
intree:         Y
vermagic:       3.13.0-66-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        1C:A1:9C:B2:D4:52:43:6B:0D:71:F1:84:5E:5C:DC:5A:D4:4A:7D:B8
sig_hashalgo:   sha512

To connect via PPP, I have been doing this…

sudo minicom -s

then setting up the device @ /dev/ttyUSB2

I get OK’s back when I issue AT, and when I send the modem ati5 I get device info back.

When I issue the at+cfun=0 command, the lights go off. When I issue at+cfun =1 then the PWR light on the 313U just blinks amber.

So the device seems works w/ the computer no issues, but I can’t connect to the APN that Embedded Works provided me.
When I provide the APN to the device via


I get an OK back.
But when I send the manual connect command:


I get “ERROR” response back.

I also get “ERROR” back when I try any ATD command.

Any help or guidance would be very much appreciated. I actually have no real background with cell modems, but I have loads of background with ethernet, Linux, and old Hayes modem commands so I believe there is just something simple I am either missing or don’t fully understand re: cell modems.

Thank you!

You can check the error by providing AT+CMEE=1 at the beginning. Also make sure your SIM is registered to network.

Did you try with the same SIM in mobile phone and is working?


Hi Alex: Thanks for the reply!

I actually don’t have another device that can use the large SIM card that this 313U uses.

After I set AT!CMEE=1, and then tried to connect I got


When I looked up error # 30, I found this message means No network service. I have an AT&T iPhone that works fine, so I assume there is an LTE tower close enough.
Here is the output when I issue AT!GSTATUS?

Current Time:  1255             Temperature: 31                                 
Bootup Time:   1                Mode:        ONLINE                             
System mode:   LTE              PS state:    Not attached                       
LTE band:      B17              LTE bw:      10 MHz                             
LTE Rx chan:   5780             LTE Tx chan: 23780                              
EMM state:     Deregistered     Attaching                                       
EMM connection:RRC Idle                                                         
RSSI (dBm):    -68              Tx Power:                                       
RSRP (dBm):    -111             TAC:         0000 (0)                           
RSRQ (dB):     -20              Cell ID:     029C7D11 (43810065)                
SINR (dB):     -5.0                                                             

Also, here are the responses from AT+CREG?, AT+CPIN?, and AT+CSQ?

+CREG: 0,2                                                                      
+CPIN: READY                                                                    

I pinged Embedded Works for support, but they don’t support Linux users. I am sure they would respond if there was some network/data plan setup issue, but I am at a loss as to what to ask about. Any advice would be awesome. Thanks!

From your command results, you can see that the module is not attached to the network. You can check the signal strength using AT+CSQ command. Also is it the same SIM card working on your mobile ??