Setting up NSSAI for 5G

Hi all,

Anyone can help on the AT command ‘at+cgdcont’ to set up nssai for 5G pdu session establishment?

For example,
at+cgdcont=1,“IP”,“internet” //this is successful

But when trying to add nssai, it always failed:
at+cgdcont=1,“IP”,“internet”,0,0,0,0,“01.000064” //return Error, when setting up slice 01.000064

Tried many other combinations of the slice, which is defined as string and hexdecimal, still didn’t work.
The modem doesn’t like the formats of the slice settings. Any working examples?

Thanks much,

Hi Frank,

this is not the correct position for the <S-NSSAI> parameter according
to TS 27.007. Also values which you don’t want to specify are typically
left empty. Please try something like


Hi Reinhard,

Thanks for you quick response. I tried your suggestion, NSSAI on the 18th parameter (17 commas) and it still returned error.
Tried many other formats on “01.000064”, also errors.
Current firmware shows:
Revision: SWIX55C_01.07.19.00 000000 jenkins 2021/02/11 02:17:18

Do you think upgrading to SWIX55C_02.08.01.00 will help?


Hi Frank,

I don’t own a EM919x myself so somebody from SIerra Wireless support would have to
advise whether a firmware update might help here.
When trying to set the S-NSSAI parameter with AT+CGDCONT on a SDX55-based platform of
another UE vendor for comparison it also returned ERROR for me.

My impression is that support for slicing generally does not seem to be fully functional
for SDX55-based devices yet.


Thanks Reinhard.
The S-NSSAI command is defined in 27.007 V16.9.0 (2021-06):
: string type in hexadecimal character format. Dependent of the form, the string can be separated by dot(s) and semicolon(s). The S-NSSAI is associated with the PDU session for identifying a network slice in 5GS, see 3GPP TS 23.501 [165] and 3GPP TS 24.501 [161]. For the format and the encoding of S-NSSAI, see also 3GPP TS 23.003 [7]. This parameter shall not be subject to conventional character conversion as per +CSCS.

But I am not sure this para is optional or not. So yes SDX55-based devices may not need to support it.
My issue is that, when activating PDU session establishment with:
The AMF rejects with 'No network slices available (#62)". That may not be related to modem.