Sending Blank SMS Messages


#1

Hey Guys,

I’m having an interesting issue where i’m sending blank SMS Message (either through at commands or via OpenAT App).

Is there something that I need to do prior to sending? It’s not the sim card that i’m using as I’ve chucked that into my personal cell phone & it works as expected.

The previous sim that I had worked, but I can’t for the life of me remember if I needed to issue any commands (at or openat) to get it working (actually, i’ve tried a couple of sims that send blank msgs).

Any ideas? Any information would be most appreciated :slight_smile:


#2

What issue :question:


#3

Oops, sorry I should have been more clear :stuck_out_tongue:

I am actually attempting to send SMSs with text in them, but they are coming through on the receiving phone as blank (i.e. no text at all).
When I take that sim & put it into my cell phone, any text that I send is received as expected.

I’ve tried it via the OpenAT api, AT commands and using the discovery tool and they all send blank texts even though I am attempting to send an actual message.

I have sent sms this way before, but it was a different sim & board (the boards are the same, it’s just another of the same board . . .).
My thoughts are that initially I setup something so that the SMSs went through fine and I’ve just forgotten what it was.

Any suggestions would be most appreciated (I hope I’ve clarified myself this time :blush: )


#4

Are you sure it’s really no text at all - or just that the phone can’t display the text?

Are you sending in Text or PDU mode?


#5

I’m sending in Text mode (AT+CMGF? returns 1 to confirm this).

I also tried sending to a couple of different phones and none of them where able to display the message.


#6

Right, it looks like I’ve got somewhere with this.
I was able to find another sim that ‘worked’ that was in an older test board.

Through a series of tests (i.e. old sim in current board works, current sim in old board doesn’t etc.).

What I was able to observe was that the SIM that worked had a config like so:

AT+CSMP?
+CSMP: 1,167,0,0

Whereas the Sim that didn’t work looked like:

AT+CSMP?
+CSMP: 1,167,0,12

My understanding is that the 12 represents the encoding.

So for a work-around for the moment is to execute this on start-up (at the proper time of course :slight_smile: )

AT+CSMP=1, 167, 0, 0

Which works (although might not be the most elegant).

Is anybody able to shed any more light on the subject?


#7

Yes I had this problem with SIMS from a carrier roaming on the vodafone New Zealand network. Vodafone SIMs are fine, roaming SIMs SMS are blank as you say, thank you, you provide a solution!


#8

Again, have you determined if they are actually blank (ie, no content at all), or if it’s just that the phone is not able to display the content…?


#9

Hi awneil, sorry for the delay in replying; been a bit busy :slight_smile:

From my point of view this is a solved issue i.e. changing the encoding meant that the messages were displayed on the phone end (and thus makes it usable).

I would dare venture that this would indicate that it wasn’t a blank message but a message that the phone couldn’t display (as you had suggested).

I’m not to sure how I could 100% confirm this nor can I spend to much time on this as there are ‘more pressing things’ to be developed : P
But if anyone does have any suggestions or ideas that I could (quickly) try out, feel free to pass them on and i can see what I can do.

Thanks