RV55 Serial data to Ethernet on MG90

I’m working on connecting several RV55 routers to serial devices, and I want to receive their data through an ethernet port on an MG90. We’re aiming to have multiple RV55s sending data back to one MG90.

I tried using SLIP and PPP for the connections, but no luck getting it stable. Can you guys help me out with a few things?

How do I set up the RV55 and MG90 for this kind of serial to ethernet communication? I’m looking for any straightforward steps or settings that could help.
Got any tips or best practices for managing multiple RV55s with a single MG90? Especially anything that might make SLIP or PPP work better?
Is there any additional hardware or software I should be using?

I really appreciate any guidance you can provide to make this work smoothly. Let me know if you need more info.


Hi @jrodeo,

Could you please provide a connection diagram for better understanding?
From the description, I understand that you want to send data from devices connected to RV55 through serial cable, and then the RV55 sends the data to the MG90 via Ethernet. Is that correct? If not, please describe it more clearly.


MG90 Testing - redacted.pdf (86.0 KB)

I’ve uploaded a .pdf connection diagram, but here’s the short version in case it’s unsuccessful:

Serial Device (PLC) — [RS-232] — RV55 ~~~ [Cellular] ~~~ MG90 —[Ethernet]— PC

For testing, I’ve got a PC serial port connected to an RV55 on one side, and a PC listening on port 40405 on the other.

Initially I tried using PAD (as described in ALEOS 4.16.0 Software Configuration User Guide for AirLink RV55 (Figure 12-9 is what I’m trying to do) and was successful passing data from one RV55 serial port to a remote RV55 serial port over cellular, but what I need to do is go from the remote serial device to a local PC (with the PC to router link being ethernet)

I also tried using port forwarding over a SLIP or PPP connection but didn’t get very far.
I attempted to use RASDIAL on the PC for its PPP support, but Win 10 wouldn’t recognize the connection without the AT command set.
I tried defaulting to AT at startup, but didn’t get very far - dialing the remote device didn’t work, and just going “off hook” didn’t work.

I can go into further details on things I tried unsuccessfully, but I think it makes the most sense to find out how this is typically done, then focus on that.

Let me know if you have any questions, and I appreciate any feedback!

Hi @jrodeo,

Please refer to the following configuration guide to see if it helps you: