RV55: change to command mode (AT) through serial port issue

Hi all, I want to change a RV55 modem to the command mode through the serial port and then run commands like “AT*NETRSSI?” to check the status. I use Putty to communicate with the modem. After I run “+++”, it returns “OK”. (I have another Ethernet communication with the modem just to confirm the modem is in AT mode at this moment.) However, if I run “AT*NETRSSI?” right after, it does not return anything, no RSSI value or “OK”.

Anyone has any idea about what’s going on? Any help would be appreciated.

Hi @tang.lei,

  1. Please share the screenshot of ‘Dual Serial’ tab on ACEmanager with me.
  2. What ALEOS version is the RV55 running, and which radio firmware is it using? If possible, please provide the RV55 template file to me.
  3. Please try entering different commands (e.g., AT, ATI1, ATI2, etc.) to see if you receive a response.
  4. How many RV devices do you have? Have any other RV devices received a response from that command?


Hi @jerdung,

Thanks for your response. I attached the screenshots of the serial port settings and the ALEOS version. I also attached a screenshot of the response from the modem after sending “+++” and “AT*NETRSSI?”

A few things I found:

  • The modem automatically swithced back to the startup mode (PPP) in less than 10 seconds after entering the AT mode.
  • I tried different commands. They got no response either.
  • I have a LS300 modem with ALEOS v4.4.9. It has the same symptom.
  • About 7 years ago, I developed an application to check a LS300 modem status through the serial port. It worked well at that time. I don’t remember its ALEOS version, but it was older than v4.4.9 for sure.

It seems to me the issue was introduced by new firmware. Please let me know what you think.



Hi @tang.lei,

Please set the Startup Mode Default to Normal (AT command), then press Apply and Reboot to see if you can enter the ‘AT*NETRSSI?’ command.


Hi @jerdung
The modem does return response after I set Startup Mode to Normal (AT). Not sure why it does not respond when using the command to switch the mode to AT.

We used to set Startup Mode to AT and our system software ran a command to change it to PPP. But we noticed that the mode sometimes automatically changed to AT on its own. Since then, we set it to PPP.

Hi @tang.lei,

You received a response after entering the AT command, did you? If there are any other issues, please let me know.


Hi @jerdung
If Startup mode is AT, I can receive a response after entering the AT command.
If Startup mode is PPP, after changing the modem to AT mode by sending “+++”, I cannot receive a response after entering the AT command.

Thanks for your help.

Hi @tang.lei,

I have reproduced this issue. Please send an email to technical support at support@sierrawireless.com for assistance.


Hi @jerdung , I just sent the email. Thank you very much for your help.