RV50X with 4.17 OpenVPN Service Failed

I’ve set up an OpenVPN server that I am able to connect the LX40 modem to, running 4.17.1 firmware and properly connect and interact with it, and LX40 properly routes traffic to port forwarded device underneath it.
The problem arises when I attempt to use an RV50X to connect to the same VPN; one of two things happen.

  1. with firmware 4.16, the RV50X connects to the VPN, however, the modem does not properly route port forwarding to the devices under the modem, rendering my configuration useless.

  2. with firmware 4.17.1 the RV50X does not connect to the VPN. The log shows only a single line indicating the a failure:

Apr 19 00:35:30 [notice ] ALEOS_VPN Reloading VPN tunnels
Apr 19 00:35:30 [info ] ALEOS_VPN Starting VPN tunnels
Apr 19 00:35:31 [debug ] ALEOS_VPN Using strongSwan
Apr 19 00:35:33 [err ] InitNG Service daemon/openvpn/1 FAILED.

I read some posts about the updated OpenVPN client, where they change the way the application is launched, init.d versus systemd but I’m not sure about those details. Perhaps Sierra/Semtech updated the application but didn’t update the method of which it is launched.

Does any one have any experience with this or advice on how to solve this? otherwise, perhaps this is a bug.
Both RV50X and LX40 use the same configuration for OpenVPN, including ca certs, tls, but each have unique client certs and keys. Again, the RV50X connects with 4.16, but fails with 4.17. Where 4.16 doesn’t handle port forwards properly (as noted in the 4.17 release notes).

Thank you for your help.

Hi @michael.mensingerjr,

Welcome to our community!

Please share the log file and template file from the LX40 and the RV50X with me.


Hi jerdung,
I’m sorry I haven’t replied sooner, and thank you for responding.
I saw yesterday that there’s a newer build for the RV50X, 4.17.1 build 006.
I updated the firmware and it fixed it.

and as of right now, digging into the log file and config settings for the LX40 versus the RV50X might be mute. they were essentially identical. I’m just happy it’s working.