RIL 8.1.2 does not create the /dev/qcqmix node on Android-x86 platform

Okay, so what should I do to make it registered?

You can try other sim card or operator.

logcat_Oct3_updated.txt (139.2 KB)

Hello,

I have already tried with different SIM so I do not think it is the SIM card issue. I took another radio log, here, we can see it is registered the SIM network but somehow it is not bringing up. Please check the below text from the attached log.

10-03 16:31:51.632 I/use-Rlog/RLOG-AT( 1169): — AT+COPS=3,0;+COPS?;+COPS=3,1;+COPS?;+COPS=3,2;+COPS?
10-03 16:31:51.632 I/use-Rlog/RLOG-AT( 1169): at_port_setup started
10-03 16:31:51.632 I/use-Rlog/RLOG-AT( 1169): AT(14)> AT+COPS=3,0;+COPS?;+COPS=3,1;+COPS?;+COPS=3,2;+COPS?
10-03 16:31:51.635 D/use-Rlog/RLOG-AT( 1169): readline received cmd(b): o
10-03 16:31:51.637 I/use-Rlog/RLOG-AT( 1169): AT(14)< +COPS: 0,0,“Jio 4G Jio 4G”,7
10-03 16:31:51.637 I/use-Rlog/RLOG-AT( 1169): AT(14)< +COPS: 0,1,“Jio 4G Jio 4G”,7
10-03 16:31:51.637 I/use-Rlog/RLOG-AT( 1169): AT(14)< +COPS: 0,2,“405857”,7
10-03 16:31:51.637 I/use-Rlog/RLOG-AT( 1169): AT(14)< OK
10-03 16:31:51.638 I/use-Rlog/RLOG-RIL( 1169): swiril_cache_set: updating cache for OPERATOR
10-03 16:31:51.638 D/RILJ ( 1695): [3691]< OPERATOR {Jio 4G Jio 4G, Jio 4G Jio 4G, 405857} [SUB0]

I have noticed that the firmware version of the modem is a bit older(2017), can we try by updating it to the latest?

logcat_Oct4_airtel_oreo.txt (175.6 KB)

@jyijyi,

As per your suggestion, I have tried with the different SIM card, now it is registered but not could not bring the network up. The radio logs are attached for the reference.

Do you think the APN settings are missing? Let me know if you want any more information or logs.

Thanks,
Hardik

What is the return of at+cgdcont?

+CGDCONT: 1,“IP”,“airtelgprs.com”,“0.0.0.0”,0,0,0,0

If you suspect apn problem, you can stop the ril and try at! scact=1,1 and see if there is error.

I am receiving an error while sending this command, please check below:
Command: echo “AT!SCACT=1,1\r\n” > /dev/ttyUSB3
Response: ERROR

Command: echo “AT!SCACT?\r\n” > /dev/ttyUSB3
Response: !SCACT: 1,1
OK

I have tried by applying CMEE=2, however, it is not showing me any specific reason for this error.

It seems already enabled, can you try after boot up?

Tried after boot up and seems ok.
AT!SCACT=1,1

Now, what other things I need to check for, please guide.

In logcat_Oct3_updated.txt, line 1106,
10-03 16:31:52.086 E/DCT ( 1695): [0]mAllApnSettings is null!

The log shows that no APN was found.

You can add APN manually:

  1. Settings
  2. More Networks (or Cellular Networks)
  3. Mobile Networks (or Wireless and Networks)
  4. Access Point Names
  5. Add New APN
  6. after edit value , right top clip “SAVE”
  7. choose the APN.

Hello,

We are not able to set the APN manually, it crashes as we click on the mobile network. Please check the below attached image for the same.

Also, please check log file: logcat_Oct4_airtel_oreo.txt, we are getting invalid subscription ID, that is why we are not able to detect the SIM.

Can you please look into this, what can be the problem? Any hint would be appreciated.

Thanks,
Hardik

You might try to add apn manually to system/etc/apns-conf.xml

@jyijyi,

In the xml file, APNs are there, I have tried with different SIM which APN is already there. I think the problem is something different.

I have noticed that, the subscription ID is always getting -1 or -2, that is why the radio turns off and could not detect the SIM card as well. Do you have any idea why the SubId has negative value always?

Regards,
Hardik

no idea.
i remember in Android 9, I need to enter "setprop persist.sierra.sim_ready_delay 15 "
If you suspect SIM problem, you might give a try on that.