Cellular NW does not bring up on Android-x86 platform

Hello Team,

I have integrated the RIL source 8.1.2 into my Android source based on the Android-x86 platform. We are using EM7455 modem. I am not able to bring up cellular network in my tablet. Below are my observations let me know if I can provide any logs.

Observations:

  1. Gobinet, sierra & usbnet modules are loaded.
  2. All the serial USB nodes are created (/dev/ttyUSB*[0-3]) and /dev/qcqmi0 node is also created.
  3. Tried applying the AT command manually and responses seems OK, checked the SIM card status and it was READY, but somehow in the GUI I am not able to see.

Please guide me to solve this problem, Thanks in advance.

Thanks,
Sateesh

@venkatasateesh41 can you help to capture radio logs?
radio log can be gotten by “adb logcat -v time -b radio” .

Thanks,

logcat_Oct3.txt (103.8 KB)

Hello @wzhang,

The radio logs are attached on behalf of Sateesh. Please check and let us know what we are missing.

Thanks,
Hardik

Is this same issue as this one?

Yes, both are the same issue, my Team member has created this, you can reply on that thread.

@jyijyi From the radio log,

getServingNetworkQMI registrationState : 3
10-03 11:00:24.184 D/RILJ ( 1774): [3685]< VOICE_REGISTRATION_STATE {.regState = REG_DENIED_EM, .rat = 0, …

This means the registration to network was denied. So your SIM may not registered. Please change another SIM.

Thanks,

Agree with you, i already pointed out this in another forum thread.

logcat_Oct4_airtel_oreo.txt (175.6 KB)

Hello,

I have inserted another SIM card and radio logs are attached for the same. With this SIM card, I am not receiving the registration denied message but still unable to bring the cellular NW up.

I think the APN setting is missing, could you please check the logs and let me know?

Regards,
Hardik