Reset EM7455 PID

I changed my Lenovo EM7455 from Lenovo PID to Generic PID (9071/9070) using
AT!USBPID=9071,9070. Purpose was to be able to use latest driver from Sierra Wireless instead of older Lenovo driver.

This command worked, but now my laptop’s BIOS rejects the card preventing me from booting (Lenovo X1 Yoga whitelist wwan). I did not know my laptop had a whitelist otherwise I would not have done this.

What is the easiest way to reset it back to factory Lenovo PID? Again the laptop does not boot at all. Is there a reset on the em7455 to make it go back to factory settings?

when running commands like AT!USBPID=9071,9070, does modify flash memory or nonvolatile memory or will it reset when I remove the em7455 so it won’t get any power?

Thanks for helping.

To your question: At the moment, with your Yoga laptop, you are not able to revert the changes or reset the module. It will be detected when you turn on your laptop. There is nothing you can do except the two methods mentioned below.
The applied changes are written in non-volatile memory and will not be resetted if you remove it.
And you will not be able to use a generic EM7455 module in your laptop.

There are two methods for reverting the PID changes you’ve made.

  1. Remove EM7455 from the laptop, boot up Windows, put your laptop to sleep, then install EM7445 and connect the antennas. Then wake up the laptop.
    This method is described on this site: … born-king/
    It’s somewhat risky, but you can apply it immediately.

  2. Use a M.2 to USB adapter. You can install the generic drivers from SW. … _PrefLoc=2

Good luck

Thanks for the wonderful suggestions. I used Method 1, which worked perfectly. I had already counted on being without a laptop until I got an M.2 to USB adapter but fortunately it will not be necessary. I am up and running again.

I read on some Russian forum the idea to keep the bootpid to what the BIOS wants and the regular application PID to generic but that did not work: on a warm boot the BIOS detects the generic ID and still refuses to boot. So I gave in and set both PIDs back to Lenovo (9078&9079). So now I am in the same place where I started.

I hope I will at least be able to use newer firmware as the generic firmware is newer ( than the Lenovo generic firmware (02.08.xx.xx). Even that is hard because when applying the firmwares from source.sierrawireless the driver notices the change and wants to revert back to the older firmware. What registry key can I change to stop this behaviour? The latest Lenovo drivers do not look like the generic drivers anymore and there is no configuration.ini to set FWUPDATE=0 etc.

This is probably off-topic here, being Lenovo specific, but FWIW: The latest Windows driver package for my X1 Carbon mounted EM7455 includes firmware. The same goes for the latest Dell DW5811e drivers. And both those driver updates came before before that firmware version was made available on source.

True I did see that it included the new firmware but somehow for Image 6, GENERIC, it was still using the older firmware. My T-Mobile USA sim corresponds to generic. I did see that for other carriers, like, the firmware was the newer one. Now what I did was to manually replace the .nvu and .cwe files in Generic/6 directory and so far I am fine with it.

I have had the problem of GPS stopping i.e. when I start in Windows maps the em7455 GPS it works but then after a few minutes it just stops tracking even though the satellite reception is the same. It never recovers on its own. Sometimes it is enough to restart the maps app. Otherwise an AT!RESET fixes it for a while.

The GPS problem seems to be solved with the newest firmware My EM&MC7455 work now flawlessly with Windows Maps.
You can flash your Lenovo-branded EM7455 with it.

Thanks for pointing this out as it was bothering me a lot. Yes, I can confirm that fixes the GPS! Yay! Using T-mobile USA.