RC7620 cannot connect to the network


I can get the IP address of the module by command (at+cgcontrdp?)
I manually added the IP address and netmask to the OS.
But can’t ping
Even with udhcpc it fails too.

seems you can do it last week:

Not like last week.
I was able to connect to netweek last week, but I can’t connect to the test today.
AT+CGCONTRDP? can know IP and manually add to Linux ubuntu.
I’ve tried more than two modules with the same problem of not being able to connect to the network.

what is the difference between today’s test and last week’s test?
module? FW? SIM? host? network?

One module tested last week and two different modules.
Use the same OS and SIM card.
All have the same firmware version Release 8.
May I ask the connection process of the RC module?
Please suggest how to deal with this issue.
Many thanks.

you can see here:

Hard to troubleshoot if it worked last week but suddenly not working today

We found the AT command (AT+CUSTOM=“DHCPRELAYENABLE”). It seems that the default is to use the internal DHCP Server.
I have two questions.

  1. Could the default lease time of Internal DHCP be adjusted? How to adjust it? It seems that if the DHCP
    Client does not specify a lease, it is 7200sec.
  2. Does RC76 only work with DHCP Client?

what is the relationship to the original topic?

We will AT+CUSTOM=“DHCPRELAYENABLE”, 1 whether we manually add IP to the system or use UDHCPC, we can’t ping AT!SCACT=1,1 responds ok.
We set AT+CUSTOM=“DHCPRELAYENABLE”, 0 and manually add the IP to the system to ping, but it will be disconnected in about 2 and a half minutes and the AT! SCACT parameter is automatically switched from the original 1 to 0, but it does not work with UDHCPC This problem AT!SCACT parameter will always remain at 1.
We are not sure whether the command AT+CUSTOM=“DHCPRELAYENABLE” will affect the connection.

By the way, have you tried manually adding the IP in the OS and not using DHCP to ping

no, never tried manually setting IP.
BTW, you can try with the MBPL connection manager sample application and see if it works