RC7620-1 PCM problem

I used RC7620, it can make a voice call, I got PCM signal. Now switching to RC7620-1, no PCM signals got although ATD return OK and CONNECT.
Any glue? All modules are tested on Mango Yellow.

Never had this problem with the RC7620 cat 4?

We also have this issue here, nothing helped… let me know if you have any solution.

@PAT : RC7620 Cat 4 had problem with CMUX and unresponsive AT command.

Good to know, RC7620-4 and RC7620-1 behave certainly the same.
The fact there is no PCM signal during a call is not fully reproductible, you probably had the “chance” it works each time with the cat 4…

The big problem is that bugs are unpredictable. It appeared and reset module can make it unpredictable disappear/appear.

It seems the issue appears each time after powering on the module, but unpredictable during lifetime.

Do you see the same behaviour?

@PAT, @nguyenducminh

What firmware are you using?

Can you also try the below commands, it might help, we have found an issue with PCM where PCM might not be activated when a call is up which is bizarrely enough caused by the NMEA port on USB not being enabled (given how isolated these areas of code are its taken us a bit by surprise) so it has only shown up in the non GNSS modules, not cat 1 vs cat 4. I don’t know if that’s a difference between your units as well?

at!entercnd="A710"
OK
at!usbcomp?
Config Index: 1
Config Type: 1 (Generic)
Interface bitmask: 00080109 (diag,modem,rmnet0,ecm)
OK
at!usbcomp=1,1,0008010D
OK
at
OK
at!usbcomp?
Config Index: 1
Config Type: 1 (Generic)
Interface bitmask: 0008010D (diag,nmea,modem,rmnet0,ecm)
OK
AT!RESET

Regards

Matt

Hi Matt,
It solved the problem. Great thanks.
Have you found the solution for stuck AT command via UART?
Minh

@nguyenducminh

What firmware are you using? For UART operation on RC7620 you need to be on R8 as it has a lot of fixes for this in, of R6.3 for RC7611.

Saying ‘unresponsive’ for CMUX is a little difficult as it could easily be down to minor incompatibilities in the CMUX implementations on either end and these can be difficult to find but generically speaking we do not have issues with CMUX so you are going to have to be a little more detailed in your issue description.

Regards

Matt

Hi Matt,
We used R8. We reported the issue of unresponsive AT command here:
UART AT Command hang when make a phone call - IoT Modules / RC76 - Sierra Wireless Forum
Please help us.
Thank in advance,
Minh

Seems to work here too! However I only made some rough tests.

We also use a firmware based on R8 and still have URC issues during a call.

1 Like