RC7611 becomes unresponsive


We are facing a major communication issue with RC7611.

We use a code block that continuously issues command AT+CPMS? to the modem to check for incoming SMS messages which has been working without any problems with quite a number of modules, like HL6528RD, RC7620 etc. We tried to use the same code to communicate with RC7611 but after a short while the modem fails to respond. The only way to re-establish communication is to reset the modem.

Most of the times the problem appears very early. In the first 100 iterations (after a power-up/reset). There has also been cases that the problem appeared later (after the first 1000 or 2000 iterations).

The issue is not related to the specific command (AT+CPMS?). We made a simple app that constantly sends the same command to the modem and reads the modem’s response and the problem appears even with the most simple command (“AT”).

The same app works fine with RC7620 modem which never stops responding.

We also tried applying a delay after each iteration but the problem persists.

We use the latest modem’s firmware (Release 9.0).

Has anybody faced a similar issue?

Problem solved.

In order to fix the problem you need to enter the following commands: