RC6720 low power modes

I am new to the RC7620. I am moving from a module that is able to maintain a TCP/IP connection whilst sleeping when no data to send. The current module goes to sleep ~1 second after the last packet is sent and wakes up very quickly when more data is sent. We do this in USB mode and UART mode. It sleeps at circa 3mA. Can anyone confirm whether the RC7620 should perform similarly?

i remember when TCP socket is opened, the sleep current consumption might be higher than usual

Probably you need to do some testing

Do SW offer a development kit / evaluation kit to evaluate RC modules?

I used the old HL dev kit
also some people use the mangoh green board

Probably you need to double check with the distributor

We have been testing and struggling.

Using UART only. We find the UART is sleeping -we have to send an extra command to wake the uart up. However the power consumption remains high - circa 15-20mA. (a bit less than the datasheet for idle but assume this is because no USB active).

I wondered whether it needs eDRx to be enabled? When we try to set it we get ERROR. Why will RC6720 not allow eDrx to be set?

How about not opening tcp socket? how is the current consumption is sleep mode?

No TCP / any sockets open. Simply we apply power.

We even tried using DTR to terminate a TCP session using DTR but the module just continued.

how about the current consumption of AT+CFUN=0?

No change.

We do see the current drop if we use POWER_ON_N

then this is not related to eDRX

AT+CFUN=0 already shut down the telecom stack, this is not related to network such as TCP socket anymore.

So probably an issue with hardware I/O then?

it could be, i am not quite sure

Ok - we have been taking the dev board apart. It seemed to be the USB connection (USB_VBUS).

We now have sleep current at the right level for KSLEEP = 2 (no sleep) and 1 (we saw the 5 second).

Our issue is that KSLEEP = 0 does not care what state DTR pin is (0, 1 or floating). We simply see sleep after 5 seconds. We query KSLEEP to confirm its 0 and we have set AT!RIOWNER=0.

Why is DTR not being listen too?

Is it to do with USB? We have floated it - is that ok? Does it need to be grounded?

i just tested RC7620 in FW R8

for AT+KSLEEP=0, if i enable DTR pin, there will be immediate response on AT command in UART.
If I deassert DTR pin, I need to enter a dummy “AT” to wake up the module, after that it can response the AT command, so I believe it is in sleep mode before the dummy “AT”.

According to AT command guide, for +KSLEEP=0, If DTR is inactive, module enters sleep mode once all wakeup sources are released, so i believe that 5 seconds you observed is to wait for wakeup source released.

1 Like

Thanks so much for testing.

So something on this dev kit is causing this behaviour.

I noticed in the specification document it has a pulldown resistor on USB_VBUS. Do you think without this we might see this issue?

Otherwise when else it not listen to the uart? (When ksleep=0)

What do you mean “not listen to the uart”?
Are we seeing same behaviour in R8?

No we dont - in ksleep=0 DTR does nothing, and it just sleeps and needs AT to wake it after 5s. Its like its still in ksleep=1

On my side, I did not connect any USB cable.
do you have same setting?

Manufacturer: Sierra Wireless, Incorporated
Model: RC7620-1
Revision: SWI9X07H_00.08.07.00 0ce4c1 jenkins 2021/03/17 02:18:20
IMEI: 353635110212345
FSN: 7T118701512345


+IFC: 0,0


Please see image of our terminal.

Looks like the same settings. We are using the RC7620-1 you are using RC7620 only.

seems FW version is different