QMI SDK Flashing Tool

I have a MC7354 Module that I’m trying to flash from global to verizon on a ubuntu system. I have downloaded the QMI Samples SDK and my attempt to compile the latest has failed. I also seem to be missing the pkgs folder.

I flashed the module on a windows machine with a built-in mini-pcie and the windows FDT tool, messed up the module so now I can’t use it in linux, no interfaces nada…

So I have one more module to try with and I’m hoping someone out there can help me out or knows which compiler and info should I use to compile.
or if anyone has a mipsel flashing tool :slight_smile:

Thank you


What is mean by this? Module is detecting in Windows machine? Are you able to communicate with the module on Windows machine??


Hi Alex,

In windows I lost all my interfaces except for a mc7354 device and it has an unknown ! mark beside it. The windows flashing tools still sees the device when I go to reflash but the outcome is the same.

as for linux nothing shows up no qmi ports or ttys. I believe since I flashed the device via windows 8 is somehow changed the mode to mbim or something else.

I’m trying to get it flashed under linux but the tools seem to be missing files since that is my main system. Anyway to get a full sdk what is needed? I thought I would need to compile the firmware_tool to my system.

Thank you

Is it something related to [url]https://forum.sierrawireless.com/t/my-mc7710-cant-work-on-linux-after-plug-in-it-to-windows8/7986/5] ?


I read that post it looks like they have the interfaces which I didn’t have.

Anyways update, I managed to fix the problem by booting up into a older windows 7 and flashed it from there and got all my ports back and working. So if anyone is flashing this on windows 8 with the fdt you might have these problems.

No I need to be able to flash this from linux (mipsel) how do I get my hands on the full sdk since the one on the website is missing packages and can’t be compiled under ubuntu.

Any Help?

Thank you

What command are you giving to compile the sdk?
Also what error are you getting while compiling?
Are you using SDK version 03.03.10?


Hi Alex,

Yes I’m using 03.03.10 SDK. I tried fedora and ubuntu. I’m trying to compile the Firmware_Download to reflash a verizon firmware onto the MC7345.
so I tried following the linux guide page 16 that comes with it and well I’m missing the files under the pkgs folder. so no pkgs.mak nothing. so I tried the following
I have both a generic environment to compile normal apps and I also have a toolchain with uclibc.

I get the same errors if I run make or just make CPU=mipsel
[dan@localhost Firmware_Download]$ make
Compiling src/fwDld_main.c
obj/hostx86_64/ exists - good.
Compiling src/fwDld_9x00.c
obj/hostx86_64/ exists - good.
Compiling src/fwDld_G3K.c
obj/hostx86_64/ exists - good.
Compiling src/fwDld_9x15.c
/usr/bin/ld: cannot find -lslqsqmi
/usr/bin/ld: cannot find -lslqsapi
/usr/bin/ld: cannot find -lslqscore
collect2: error: ld returned 1 exit status
make: *** [bin/fwdldhostx86_64] Error 1

so it missing the libs to make anything. you I thought that there must be another package or dev kit to go with it?


By default, the application is compiled for i86 platform.

I guess you need to do
make CPU=



i had the same problem. the doc is wrong. i will give a short lazy howto compile the sample apps on a 64bit system. prerequisite is a multilib environment.

the makefile in the sample app directory includes the file …/SampleApps.mak. this file includes the other makefile …/…/pkgs/slqscompile.mak the default is that the slqscompile.mak finds out the system architecture with the command “uname -m”. in dans case its x86_64 (as for me). the linker tries to find the static libraries in the directory …/…/build/lib/hostx86_64. unfortunately there are no 64bit libraries existing only 32bit one. same problem is for armhf architecture (raspberry).

  • install multilib stuff (could be more or less, depending on the installed packages on the system)
    apt-get install gcc-multilib libc6-i386 lib6-dev-i386
  • adapt …/…/pkgs/slqscompile.mak to create 32bit binaries
    CFLAGS += -m32
    CXXFLAGS += -m32
    LDFLAGS += -m32
  • adapt library directory so the linker is able to find 32bit libraries
    cd build/lib
    ln -s hosti686 hostx86_64
  • goto to sample app directory
    cd SampleApps/MC7xxx_Image_Management
  • create binary
    make clean
    if everything works fine a binary is created in the ./bin directory.

hope this helps