Q2698 No response to AT - Flow control issue in V7.52?


#1

Hi,

I am using the Q2698 module in a custom PCB I had made with an ATMEL 3.3V micro. Unfortunately for us we omitted CTS/RTS lines for flow control (whoops). Anyhow we disabled flow control on the Q26 using AT commands in the Q26 V3.2 Dev kit and hey presto the module ran fine in our dev board at 19200 8 N 1. I’ve now upgraded the Q26 to R7.52 firmware and now the modem will not respond to AT commands but works fine in the dev kit. Flow control is still disabled on the module but no response to AT\r. I wrote a simple OAT app to output “Hello world” to the serial interface which I can see on my PC comm port connected to the Dev Kit USB high speed port at 19200 8 N 1 but nothing on the Q2698 TX line (pin 71) when I put it into my custom PCB.

VBatt is 4V, !RESET is at 1.8V.

It is probably something very silly that I am doing / not doing but as a newbie to Sierra modules I am completely stumped.

Any help would be appreciated on what to try next.

Kinn regards
Ian

ati9
“DWL”," SWI6200T_02.02.04.07ABT R2881 CNSZXD00000132 2013/12/20 10:43:54","",“Sierra Wireless”,0,"",“00000000”,“00000000”
“FW”,“FW_752_28_A1_12.Q268Fx”,“R7.52.0.A1.201401021703.Q2698”,“Sierra Wireless”,1770396,“010214 17:03”,“ae3e7f98”,“10002020”
“MODEM 3G+”,“Revision: SWI6200T_02.02.04.07AAP R2881 CNSZXD00000132 2013/12/20 10:57:19”
“ROM”,“8400000”
“RAM”,“4000000”
“OATRAM”,“40000”
“DWLNAME”,“Q2698”


#2

Hi Ian,

If you haven’t fixed the problem yet can you please post the response to at&v?

Thanks


#3

Hi,

That’s the problem. I get no response from the module at all to AT commands. The module seems to require DTR even when flow control disabled.


#4

Ian,

Sorry my mistake I thought I read that you could still talk to it on the Sierra Wireless dev board.


#5

Ah Sorry Ross - we were at cross purposes. I get no response in my board but do in the dev board. It’s related to DTR I think. Will post the AT&V response.


#6

Response to AT&V

Q:0 V:1 S0:000 S2:043 S3:013 S4:010 S5:008
+CR:0 +CRC:1 +CMEE:1 +CBST:0,0,1
+SPEAKER:2 &C:0 &D:0 %C:0
+IPR:19200 +ICF:3,4 +IFC:0,0
#ªè
OK


#7

Ian,

Should have said that there was something in the release notes about ICF, but what you have looks correct. Our 3 wire UART designs have DTR tied to 2V8. Have you looked at the AT+WASR? output? We had some issues with Fastracks, fine when you were talking to them on a PC (with DTR being used), but once you connect them to a device with three wires comms, no response.

Ross


#8

Hi Ross

Thank you. I will check what AT+WASR returns. What was the comment in the release notes - any chance you can point me in that direction?

What you describe is exactly the problem we are experiencing.

Thank you for your help so far.

Regards
Ian


#9

+WASR: 0,1,“GPIO24”,6

ª è

OK


#10

Ian,

Looks like the auto shut-down feature is already turned off. You could try sending AT+WASR=0,1 again just to make sure it is set. If this doesn’t work I am all out of ideas, sorry

Also from memory I think you will get an ERROR response after issuing this command, that does not mean there is a problem with the command, just that what you are trying to do has already been done.

Ross


#11

Thanks Russ. I have got the module responding now. It was due to the fact that my pull up on the I2C lines were not correct causing a power issue on the module.

I get the response to AT however this is preceeded by some strange characters - and not the AT echo which I would expect.

The response below is from at AT\r

?? OK

What is weird is that the module responds correctly to the commands. I’ve tried changing the baud rate from 19200, to 1200 and still the same.

The scope traces are here

imgbox.com/Tzn5zu4P
imgbox.com/TlRErJzT

I used Picoscope to decode the oscilloscope and get the AT response as

0xAA
0x06
0xE8
0x0D
0x0A
‘O’
‘K’

Any ideas?

Thanks
Ian


#12

Hiya,

I ran into a similar issue when migrating my Q2686 design to the Q2698.

The PTS says that uart 1 on the Q2698 is 3v3 tolerant. I used the same ftdi 3v3 usb to serial adapter that I used on the Q2686 and could only get gibberish. Once I started using a 2v8 serial interface chip to interface to a usb to serial adapter I had no further issues with getting gibberish on uart 1.

I will admit that I have a 5 wire interface rather than a 3 wire … but it might be worth trying a 2v8 serial interface in your situation.

Ciao, Dave


#13

Thanks Dave.

I’ve found out that it was not electrical problem as the pattern was too repeatable.

Instead the module was in DEVELOPMENT mode from the Sierra Dev Kit.

So I issued an AT+WDM=0 and all is well! The AT+WDM=1 must wrap the AT commands into a header and footer.

01234567890!@#$%^&*()abcdefghijklmnopqrstuvwxyz
FRAM Done
Initialisation complete
3G Power On
Q2698HSPA Low
Q2698HSPA Reset
AT
OKQ2698HSPA On
Session open
RTC 11/10/2014 12:17:6
Intialising modem

AT+COPS?
+COPS: 0

OK
AT+COPS?
+COPS: 0

:smiley:


#14

do you have any surplus Q2698 ?