Q2686 - CMUX - Hardware Flow Control


I’m trying to develop a Cmux based app, running on a arch-specific system, and I need to get CMUX working.
Obviously I need to get hardware flow control to avoid loosing data (AT+IFC=2,2).

The problem is that whenever I start CMUX (AT+CMUX=0,0,5,127) then I completely lose contact with my modem and I can’t event start the control channel nor restart it (excepts from physically restart it, of course). I tried without flow control (and used AT+IFC=0,0 - to unset flow control on the modem) an it works, but as suspected, I get to lose characters.

Do you guys have any clues to what is wrong ? And a way to solve this ?

I hope it’s clear enough and if not, feel free to ask.

Thanks in advance.

Modem version :
AT+WHWV = Hardware Version 4.03
AT+CGMR = 663c00gg.Q2686H 1961896 122407 14:45

Modem settings :
Default +


Have you got a USB port brought out on the hardware you are using?

For testing purposes, you might be able to control your modem via the USB interface (which has standard AT commands) while debugging your CMUX interface over the serial port …

ciao, Dave

Hi and thanks for your answer.

Unfortunalately, I haven’t a USB interface, so I can’t get any intel on what’s going on…

Hope you have any other idea, I’ve been trying to get this working for a week now and not even a single step forward …

Thanks again,


Any other interfaces - another UART? SPI? I2C… :question:

No, really, I don’t. Well, to be precise, I’m not really sure.
I’m not used to work with this kind of material, so maybe I’m wrong.

Btw, I guess this is not a problem with my modem, I ported my app to run on a Linux env and it worked perfectly.
So, guess I should have done this before coming here…

Sorry for the inconvenience. I’ll try to get in touch with the constructor of my system architecture.

Thanks again !