PSM activity timer


I am measuring power consumption and have come across an issue. Here is a graph of the wake up:

The first part of the wake up we do our thing, wake up 7800, send some data and then go back into hibernation. Instead of going to sleep right away it seems the 7800 continues to receive paging for 10-11 seconds (the highlighted part)?

I tried configuring the timer for both 2 seconds and 24 seconds however the graph always looks the same. I expected to see a difference but its always 10-11 seconds. The network does accept the PSM settings in both cases:

+CEREG: 1,“D8D6”,“0843A40C”,7,“00000001”,“00111000”


+CEREG: 1,“D8D6”,“0843A40C”,7,“00011000”,“00111000”

Thoughts? This power draw is significant and we could extend the battery life by ~50% if this can be shortened.



Did you shutdown edrx mode?

Did you change the state of wakeup pin?

Does it happen the same if you configure longer timer for +cpsms?

I tried with eDRX both enabled and disabled, no difference.

The wake up pin is cleared at the first marker. After the 11 second wait I get:

+CEREG: 4,“00000001”,“00111000”
+CREG: 4

I tried both 2 seconds and 24 seconds (always takes 10-11 seconds). You want me to try something even longer?

Yes, try to sleep for 30 minutes, is it the same?

Its set to sleep for 24 hours but only be active for 2 seconds?

You can change it , right?

Ok I will try with 30 minutes instead of 24 hours.

Btw, is the current dropped after those 11s paging?
Also can you try longer value for the active timer? It seems 2 seconds are too short

Ok in this run I did 24 hours and 30 minutes active. We are not actually going into hibernation at all here. The app side is still clearing the wakeup bit though. You can see the regular 1.28 s paging intervals. You can see where the apps side wakes up sends some data and then goes back to sleep. After we send and receive some http data there are regular wake ups every 0.320 seconds for about 10-11 seconds. It also looks like we are transmitting every 0.320 seconds as well (power looks high).

So the question is why does the modem stay active for so long? I closed down the http connection. Not sure what else to try.


Have you tried latest fw?

It looks this is edrx mode more than psm mode

My firmware version is: HL78xx.

I just checked and there is a new release out Aug 12th I can try it.

eDRX is disabled with AT+CEDRXS=0, anything else I need to disable eDRX?

I tried 4.6.9 and its the same.

have you set the +KSLEEP command?
e.g. AT+KSLEEP=1,2,10

You can also try to disable the debug log:

I have also checked the “AirPrime_HL7800_Low_Power_Modes_Application_Note_Rev2_0.pdf”, it seems your module is still in sleep mode, but not hibernate mode:

Yes I am setting KSLEEP and never switched the trace mode. I know the module isnt going into hibernation in the last image. I attached another one with my original PSM settings. The apps side goes to sleep at the red arrow (everything after that is 7800). I now believe the next section is some sort of connected or short drx. After that there is a circled section that seems new, maybe because of the the newer build? Its two sections about 5 seconds long and consume ~15% of our wake up power. Can you comment on that?

Is it possible to get access to the modem logs? It would really help to debug this. I tried to enable logs I can see something on the debug uart but it seems mostly binary and not plain text?

This time seems to be better than before, right?
Is it the whole system power or just hl7800 power?

No this seems even worse than it was originally on the previous build. The only reason the last one looked like that is because you wanted me to try 30 minutes instead of 2 seconds.

In addition to 10 seconds of wasted power in connected/short drx there is now 5 second wasted after that.

What did you set for AT+KSLEEP
Especially the 3rd parameter

Ok yeah I did play with that, setting the 3rd param to 0 shortens that time and seems to remove most of the end bit (now 6% instead of 15%).

So I am still back to my original problem why does it take so long to go to sleep. Is there a way to dump modem logs?


From the application note, this seems to be normal as it is in idle for awhile before going to hibernate mode