Problems with gps_simple.c


#1

Hello,

For some days I have problems with the default project that brings the library Location, when I run the project with SL6087 and send the command AT+WOPEN=1, in the TM Console show me the following parameters:

AT+WOPEN=1
OK
+GPSEVINIT: 1
+GPSEVSTART: 0

And don’t continued with the program and show me the next trace [GPS_SIMPLE] event: GPS_START_ERROR_EVENT. I review the file Location_Plug-In_for_Open_AT_Development_Guide.pdf and have compared each of functions and structs with the program generated with the Developer Studio and I don’t have other thing different with the file pdf.

Thank you for your soon answer.

Pilar Alzate
Electronics Engineering Student
Universidad Pontificia Bolivariana
Medellin, Colombia


#2

So search in the source files for that text, and see what condition(s) would cause that trace to be given!


#3

Hello,

The source of problem is with the function gps_start(). The input of this function is a variable GPS_HOT_START, and this variable pertain to struct gps_startingMode_e. But this function have returned the parameter GPS_OK, as if have not a problem, but when the function gps_simpleEventHandler() look the GPS Plug-In event through switch, appears the trace GPS_START_ERROR_EVENT.

So I don’t know what to do??

What is your suggestion??


#4

Normally you get a GPS START ERROR under the following conditions:

  1. You haven’t initialised the GPS correctly using gps_init() and the correct hardware definitions
  2. The GSM module is not able to communicate with the GPS. Are you using custom hardware or a dev kit? If its a dev kit, are all the jumpers correctly set? Do you have the correct GPS (only the XM0110 works with the location plugin).

#5

Hello,

This is my answer for your suggestion.

  1. I think that I don’t have problem with function gps_init(), because the program generated the following Trace ADL 1 [GPS_SIMPLE] event: GPS_INIT_EVENT.

  2. I have worked with the Board Platform AVL_SUPPORT (2011-08-08) with the SL6087 and XM0110, but I don’t know if I answer your question about custom hardware or a dev kit. Or what do you need to know??

Pilar Alzate
Electronics Engineering Student
Universidad Pontificia Bolivariana
Medellin, Colombia


#6

Check the button jumpers on the modem (not XM extension) demo board.

If you are using UART2 for communication between XM and modem (default of gpsSimple) you must set the UART2 jumper of modem demo board on OFF position. Indeed if you set the UART2 on ON position it seems to become available for the external serial port on the board, becoming unavailable for XM.


#7

Is that an official Sierra Wireless Development kit?

The initialisation can still succeed, even if no GPS is connected since this just initialises the location plugin. The SL only starts communicating with the GPS when you start it. It first does a firmware download to the XM (rapid LED flashes for about 6 sec over UART at 921kBits per sec), and then begins acquisition. If you are using a dev kit and aren’t seeing the rapid flashing on the XM daughter board, there may be a communications issue between the SL and the XM


#8

Hello,

In the picture attached you can see, that I have worked with the UART1. So I believe that the problem haven’t relation if I connected with the UART2, because when I run the program,automatically the software connected with the UART 1


#9

Hello,

If the problem is since of function gps_init(), I don’t know to how solution this problem, because I use the sample for default bring the software Developer Studio and the program for default connect the UART1, and still the same error, you can see the time during between each trace in the picture attached.

I find this page http://ep.com.pl/files/8925.pdf, and I tried to building the project, but I have error with some function relation with the library wip, and I don’t use any function of this library.

I don’t know what I do? Any suggestion?

Nobody works with this sample that bring the software??


#10

The UART configuration you shown is correct, but gps_simple establish communication between modem and XM extension via UART2; so check the jumper button on SL6087 demo board being in off position and try to start the program.
I got the same error earlier, may be it is the same.


#11

Hello,

In this moment I search in my demo board the jumper button that you said in the last post, but I have only three switch related to ON/OFF, RESET and BOOT, you can see this switches in the following picture.

What is your suggestion ??


#12

Is this switch in the OFF position? Is the GPS daughter board correctly and firmly attached to the main board?


#13

I understand the problem, I have worked with the daughter board that you can see en in the picture. My board is so different in compared with your picture. For this reason of hardware the sample gps_simple.c have not good result ??

Hope your soon answer.


#14

Sorry, I don’t attached the imagen in the last post


#15

Ah, you are going to have to check that they have used the same GPIO configurations for RESET, SELECT, WAKE_UP, and check that the CLK_32K is correctly connected. If they are using different GPIO, update the configuration structure to use the ones connected.


#16

Hello and Thank you for your answer, but your suggestion don’t solve the problem, I have changed the configuration GPIO with the following mode (you can see that in the next code), but I have the same trace ADL 1 [GPS_SIMPLE] event: GPS_START_ERROR_EVENT

Do you have other solution?? Hope your answer and again thank for your help

#ifdef _GPS_SIMPLE_I2C_DEV_KIT_CONFIGURATION_
            // I2C Configuration
            GPS_HWTYPE_XM0110, // gps_hwType_e          eHwType;
            {
                        GPS_BUS_I2C,       // ebusTypeID: Bus Type ID
                        GPS_BUS_NUM_1, // ebusNumberID: Bus Number ID
                        20, // u16OnOffCmdID: ON/OFF Command ID //ANTES 22
                        19, // u16RstCmdID: Reset Command ID, //ANTES 23
                        24,// u16GpsRecWakeupCmdID: GPS Receiver Wakeup Command ID, //NO CAMBIO
                        GPS_GPIO_NOT_MANAGED,// u16HostWakeupExtIntID: Host Wakeup external interrupt input ID,
                        GPS_32K_INTERNAL, // e32kMngt: 32 KHz clock management
            },
#endif // #ifdef _GPS_SIMPLE_I2C_DEV_KIT_CONFIGURATION_

#17

Doesn’t your board manufacturer and/or supplier provide any example or support :question:


#18

No, my board manufacturer don’t provide other sample. But I understand that the solution of this problem is to change the structure of the configuration with the GPIO with my board manufacturer? But there is an another step that I missing?


#19

Lesson to learn: always ensure that your supplier is going to be able to provide you with the support you require!

Inevitably, one of the first things to suffer with so-called “cheap” boards is support.

Perhaps you should get hold of a proper SiWi devkit and then, once you’ve gained sufficient understanding, you will be able to get this board working…


#20

Ok, thank you for your answer