Problems when ber>0 in +CSQ


#1

We have noticed that when the channel bit error rate reported by AT+CSQ is higher than 0, sending an SMS with either AT+CMGS or using the adl sms service fails in a special way.

When using the adl service, it first accepts the call with an OK response, but the callback is never called. Wait time for callback has been several minutes with nothing.
Further attempts to use the adl sms service to send an SMS will result in ADL_RET_ERR_BAD_STATE.
This is most likely due to that the +CMGS command never returns under these conditions.

When using AT+CMGS, either the > prompt never shows up or no OK or ERROR is received after CTRL-Z to send the sms.

In both above cases, a product restart has been needed to get back to normal operation.

Other AT commands have also not worked in general after the above has been tried.

The only “solution” we’ve come up with so far is to first check that the ber field in +CSQ response is 0 before trying to send SMS.

The above problems doesn’t seem to be limited to SMS sending, as we have also noticed similar behaviour with WIP.
Under some conditions the callback that is expected upon setting up a connection never arrives, and everything seems to get sluggish, and AT commands stop working.

If anyone knows more about this problem and/or what can be done about it, please post here.