problems debugging


#1

i am using Developer Studio 2.3.0 Build Version 2.3.0.201212051546-R10684
running in a windows 7 ultimate 32 bits

application uses:
openat application framework package 2.37
open at OS package 6.37
firmware package 7.47
internet library package 5.43
location library 1.3

i can not launch a debug sesion successfully. the operations starts , download the dwl file, make a lot of readings…, but at the end of the launching process (95% after perfomr a lot of operations) i have the following error messages

“Error in final launch sequence
Failed to execute MI command:
-target-select remote localhost:10000
Error message from debugger back end:
Malformed response to offset query, timeout
Malformed response to offset query, timeout”

Some ideas to fix it?

thanks.


#2

Hi,

You aregetting this isseu while downloading the application on module(95% download and then error).Can you please try the following :

  1. Close the post ,reset the module,open the post again and try to download.
    2.Is the module properly detecting on dev studio in target management.
  2. Di you try with some other module on same firmware version or on some higher version.
    4.Also ,are you able to perform the same operation on dev studio 2.2.1

Thanks.


#3

“port” :question:


#4

Application download finish properly, after that, make a lot of another readings, and finally when tries to start the application to debug it does no work.

1)i tried a lot of times, even reseting the module where the failure happends.
it fails with usb/serial converter and with the USB port directly. so i would like to think is not the port communication,

  1. yes, it reads everything they want from it and shows in the target manegement window.
  2. unfortunately i only have this module for developing , until the first prodution prototypes comes.
    anyway if i download an application and start in production mode the module works properly.

firmware version is not my choice, so it must work with this one.

  1. i do not have previous versions of the dev studio to check.

any idea about what are the last operations, need to configure something else?

i try another time the next week.


#5

looks than somebody got the same problem before.

[url]https://forum.sierrawireless.com/t/cannot-debug-in-embedded-gdb-mode/5088/1]

unfortunately , i am still trying …


#6

There are identified issues with embedded GDB on FW 7.47.4 and 7.47.6, but FW 7.47.0 is working. Can you double check anyway which FW version you are running.
Simple check also: are you running the Debug build configuration?
As mentioned in the quoted post, Release configuration can’t be used for debugging. Anyway, DS should warn you if you’re trying to do this, but who knows… :wink:


#7

ups, i did not know there were another subversion number,

yes unfortunately i have 7.47.4.201208311102 :open_mouth:

I tryied 7.47.0 and now it works…but this was painful. :cry:

thanks daav