Problem with new firmware R71


#1

Does anybody have a problem with new firmware?

I downloaded R71 firmware into a Q2686h. After installation, some GPIO are missing.
I tried both R71-cus-q26-03.wpk with dwl-win and upgrade_to_R71_00_full_q2686h.dwl with Xmodem.
But, both of them didn’t work.

Besides, I rolled back to firmware version 6.63 and some error appeared.

Thanks in advance


#2

hmm, i can’t even get is installed. so i haven’t tried it yet


#3

I tried some GPIO’s to see how the TCU work and it worked fine. Unfortunatelly the shortest TCU tick time is 0.25ms so I’m not using this feature (I wanted to do additional uart). The main problem with R71 is that after adl_adInstall the openAT application is stopped (+WOPEN: 0). Issuing AT+WOPEN=1 brings everything back to normal, but that’s not solution with DOTA. Threfore I’m still using R70 (beta). Hopefully new version will come out soon.


#4

Hello jacfry,

Sorry to ask, but do you change the ADL Apis when you switching between R70 and R71?

Please, write down your Open AT configuration. ( compiler, module, memory size, size of binary, whether you install the compressed format… )

What is the answer for the “AT+WOPEN=7” when your the OAT application failed to start after adIntall?


#5

To Madouc,

You can download DWLWIN 4.1.6.6 from wavecom product page and also the wpk file. Does anybody know where to find the
wks(workspace) files for R71?