Problem with CM7700

Thank’s for your help !
Currently, NetworkManager success to connect over the modem. It gave me an IP, but I still can’t ping whatever on internet.

There is the result for : mmcli -m 0 :

  General  |            dbus path: /org/freedesktop/ModemManager1/Modem/0
           |            device id: 39b3d2d91464a5c5430ef1be1eda3d3e9d8266e7
  Hardware |         manufacturer: Sierra Wireless, Incorporated
           |                model: MC7700
           |    firmware revision: SWI9200X_03.05.29.03ap r6485 CNSHZ-ED-XP0031 2014/12/02 17:53:15
           |         h/w revision: 1.0
           |            supported: gsm-umts, lte
           |              current: gsm-umts, lte
           |         equipment id: 012626001644788
  System   |               device: /sys/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3
           |              drivers: qcserial, qmi_wwan
           |               plugin: sierra
           |         primary port: cdc-wdm0
           |                ports: cdc-wdm0 (qmi), ttyUSB0 (qcdm), ttyUSB2 (at), wwan0 (net)
  Status   |                 lock: sim-pin2
           |       unlock retries: sim-pin (3), sim-puk (10), sim-pin2 (3), sim-puk2 (10)
           |                state: connected
           |          power state: on
           |          access tech: gsm
           |       signal quality: 41% (recent)
  Modes    |            supported: allowed: 2g; preferred: none
           |                       allowed: 3g; preferred: none
           |                       allowed: 4g; preferred: none
           |                       allowed: 2g, 3g; preferred: 3g
           |                       allowed: 2g, 3g; preferred: 2g
           |                       allowed: 2g, 4g; preferred: 4g
           |                       allowed: 2g, 4g; preferred: 2g
           |                       allowed: 3g, 4g; preferred: 4g
           |                       allowed: 3g, 4g; preferred: 3g
           |                       allowed: 2g, 3g, 4g; preferred: 4g
           |                       allowed: 2g, 3g, 4g; preferred: 3g
           |                       allowed: 2g, 3g, 4g; preferred: 2g
           |              current: allowed: 2g, 3g, 4g; preferred: 2g
  Bands    |            supported: egsm, dcs, pcs, g850, utran-1, utran-6, utran-5, utran-2,
           |                       eutran-4, eutran-17
           |              current: egsm, dcs, pcs, g850, utran-1, utran-6, utran-5, utran-2,
           |                       eutran-4, eutran-17
  IP       |            supported: ipv4, ipv6, ipv4v6
  3GPP     |                 imei: 012626001644788
           |        enabled locks: sim, fixed-dialing
           |          operator id: 20801
           |        operator name: Orange F
           |         registration: home
  3GPP EPS | ue mode of operation: ps-1
  SIM      |            dbus path: /org/freedesktop/ModemManager1/SIM/0
  Bearer   |            dbus path: /org/freedesktop/ModemManager1/Bearer/1

There is the result for : nmcli c

NAME                UUID                                  TYPE      DEVICE
Wired connection 1  4030aba8-55ae-3ecf-aa04-b1ce2712de80  ethernet  eth0
lte                 0b36aa54-eda3-461b-992a-10767096a5dc  gsm       cdc-wdm0

There is the result for : nmcli d

eth0           ethernet  connected     Wired connection 1
cdc-wdm0       gsm       connected     lte
wlan0          wifi      disconnected  --
p2p-dev-wlan0  wifi-p2p  disconnected  --
lo             loopback  unmanaged     --

And there is the result for : ping -I wwan0 -c 5

PING ( from wwan0: 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=3 Destination Host Unreachable
From icmp_seq=4 Destination Host Unreachable
From icmp_seq=5 Destination Host Unreachable

--- ping statistics ---
5 packets transmitted, 0 received, +5 errors, 100% packet loss, time 4129ms
pipe 3

Do you have a lead on the problem?

does it work for qmicli?

You might also need to try GobiNet driver with AT!SCACT:,-d-,42n2,-d-,64/#sthash.Tnx38Q6c.dpbs

I’ve first tried with qmicli, but when I run udhcpc, it’s looping into “udhcpc: sending discover”

When I connect my adaptator to my Windows computer, I have an internet connection, but only over GPRS (2G),
Didn’t understand why it works on windows, but not in Linux, and why i have only gprs instead of lte…

why don’t you use AT!SCACT?

Have you tested if your SIM card is ok with LTE?

have you checked AT!BAND if it has LTE band enabled?

Don’t know how to use AT!SCACT

After plugged back adaptor to my raspberry, the connection is now functionnal.
But I still don’t have LTE, only 2G.

The result of AT!BAND? is :
Index, Name
00, All bands

I know that my SIM card is ok with LTE as it’s my smartphone SIM card…

have you checked AT!SELRAT? and AT!SELRAT=?

AT!SELRAT? return :

AT!SELRAT=? return :
Index, Name
00, Automatic
01, UMTS 3G Only
O2, GSM6, LTE Only
03, Automatic
04, Automatic
05, GSM and UMTS Only
06, LTE Only
11, UMTS and LTE Only
12, GSM

I’ve tried to set AT!SELRAT=06 or 11, but after that, +csq return 99,99.
It’s strange because it seems to not get 4G signal, but we are in a good coverage zone, and our smartphones have no problem to get 4g…

you can set to AT!SELRAT=6 and enter the following for more information:



Current Time:  3323             Temperature: 32
Bootup Time:   2682             Mode:        ONLINE
System mode:   LTE              PS state:    Not attached
LTE band:      B4               LTE bw:      15 MHz
LTE Rx chan:   2028             LTE Tx chan: 65535
EMM state:     Deregistered     Attach Needed
EMM connection:RRC Idle

RSSI (dBm):    -125             Tx Power:    0
RSRP (dBm):    0                TAC:         0000 (0)
RSRQ (dB):     0                Cell ID:     FFFFFFFF (4294967295)
SINR (dB):     -18.4


!SELRAT: 06, LTE Only


Index, Name,                        GW Band Mask     L Band Mask
00, All bands,                      000000000CE80380 0000000000010008


Index, Name,                        GW Band Mask     L Band Mask
00, All bands,                      000000000CE80380 0000000000010008
01, Europe 3G,                      0000000000400000 0000000000000000
02, North America 3G,               0000000004800000 0000000000000000
03, Europe 2G,                      0000000000000380 0000000000000000
04, North America 2G,               0000000000280000 0000000000000000
05, GSM ALL,                        0000000000280380 0000000000000000
06, Europe,                         0000000000400380 0000000000000000
07, North America,                  0000000004A80000 0000000000010008
08, WCDMA ALL,                      000000000CC00000 0000000000000000
09, LTE ALL,                        0000000000000000 0000000000010008

                                                     0000000000010000 - B17
                                                     0000000000000008 - B4
                                    0000000008000000 - B6  (800)
                                    0000000004000000 - B5  (850)
                                    0000000000800000 - B2 (1900)
                                    0000000000400000 - B1 (2100)
                                    0000000000200000 -     G1900
                                    0000000000080000 -      G850
                                    0000000000000200 -     G900P
                                    0000000000000100 -     G900E
                                    0000000000000080 -     G1800


+COPS: 0


+CGDCONT: 1,"IP","orange","",0,0
+CGDCONT: 2,"IP","wap.cingular","",0,0
+CGDCONT: 3,"IPV4V6","10767.mcs","",0,0
+CGDCONT: 16,"IPV4V6","BroadbandAuto.APN","",0,0

(The first APN is the good one)

How about “at+cops=?”

See if it can scan any operator

It seems to scan all french operator :
+COPS: (1,“Orange F”,“Orange”,“20801”,0),(3,“F-Bouygues Telecom”,“BYTEL”,“20820”,0),(3,“F SFR”,“SFR”,“20810”,0),(3,“F-Bouygues Telecom”,“BYTEL”,“20820”,2),(3,“F SFR”,“SFR”,“20810”,7),(0,1,2,3,4),(0,1,2)

Seems there is no orange france frequency band for your module

Strange that i don’t see B1 is supported in your AT!BAND? response…
Maybe the order SKU of your module is not supporting B1 according to PTS:


Orange France have a B28 (700 MHz)
In the product description on Amazon (where we’ve bought our MC7700), they specify :
For LTE 700 / AWS, for WCDMA 850/1900/2100 MHz, for EDGE / GPRS / 850/900/1800/1800/1900 MHz.

I don’t know much about frequencies, but it seems that there is the 700 MHz in both?

I don’t see LTE band 28 in product specification

“for LTE 700” ? Is this not the B28 ?

PTS says it is lte B17

Oh yes, indeed! But in that case, shouldn’t I have B1 in WCDMA at 2100MHz?

Do you know which model of modem will be compatible with French LTE ?

according to the PTS, some SKU does not have LTE B1