Problem in creating a TCP server?

Dear sir,
Iam using Q2687rd GSM module v7.44. iam unable to creat a TCP server in my application

wip_TCPServerCreateOpts( uPortNo,(wip_eventHandler_f) evHandler, NULL,

here iam using the port number as my system port num. this api not calling the evHandler function (no case statements are executing inside this function). please help me
what can i do for this function working properly.

thank you in advance…


Have you had a look at the TCPServer example? Lots of hints there.

ciao, Dave

i tryed but i wont get the solution

please explain with beautiful quote…

What problems, exactly, did you experience :question:

There’s no point just giving you another example when we have no idea where you’re really stuck :exclamation:

Are you familiar with the general concepts of how TCP works?

I used TCP server example
I got IP from WIP_BEV_IP_CONNECTED event and port in example application 2000
Used those details in hypertrm to create tcpclient and tried with telnet too but no luck
at the same time i was able to create tcp client to TCP server where i found the ip which is got from bearer and tcp client is different

Is there any firewall or operator masking public ip prevents to connect server

Thanks inadvance

For sure you must make sure that you MNO supply you with a public IP. Otherwise you can’t run a server. Some MNO do use private IP.

Absolutely :exclamation:

So you should be able to see whether it is a Public (aka “routable”) address or not…

In fact, most MNO use private IP; you usually have to specifically request a Public IP address - and pay a premium for it :exclamation: … _Addresses

i got public ip itself it is in WIP_BOPT_IP_ADDR by using wip_bearerGetOpts & wip_inet_ntoa
but when my socket server in host machine shows ip as as tcp client ip which i have created in modem for cross checking

I believe that both are public ips i tried to create tcp clients with both of them but no luck

Please help me out :question: