TCP server +WIPCREATE & +WIPDATA issue


#1

Hi there,

Im trying to create a TCP server socket using the M1306b modem but having some problems, the hypertext commands are shown below,

[color=green]AT+WIPBR=4,6,0
OK
AT+WIPBR=3,6,15
+WIPBR: 6,15,“10.43.2.81”

OK
AT+WIPCREATE=3,1,80,5,5
OK
at+wipdata=2,5,1
ERROR

Ive also tried +WIPCREATE=3,1,80,5,9 which brings up an error, I was expecting +WIPACCEPT:1,5 after it on both occasion but as you can see it is not showing the same results. Im really in the dark with this as the client side was ok, can anyone help please?


#2

If you create a server socket, then you need something to connect to it before you can do AT+WIPDATA=…
That connection will trigger a +WIPACCEPT:…


#3

Initially that is what I anticipated but still no result, is it true that the command [color=green]+WIPBR=3,6,15 doesn’t reflect the true IP address 10.xxx.xxx.xxx ?

Im using a web browser as a client to connect to the server for example 10.xxx.xxx.xxx:80 my understanding was the I would send http code as data to the client (server configured at this stage using hyperterminal). Has anybody got any example or am I totally off track?


#4

10.x.x.x is a Class A private network.
Unless you’re on the same private network you need to talk to your SIM provider to see if you can get a public IP mapping for the modem.