PDP context not saving to non-volatile storage

Hi,

I’m currently facing an issue with some of our modules where for some unknown reason, the PDP context refuses to properly save to non-volatile memory.

Additionally, an internal error (CME: 60) will occur with the AT+WPPP? command until I reconfigure some aspects of the context as shown below. On bootup the context will be default to only one defined context and I have to manually re-define a second one for the wppp command to work again.

Unfortunately after a reboot all of those settings are gone including context and apn’s that were defined and the device is then back to the same issue as before.

I don’t know what causes this issue, but once it is triggered it is very consistent. I’ve tried resetting to factory settings and loading other profiles but no luck. I now have a few modules showing this issue both on firmware version 4.4.14.0 and 4.6.9.4.

If you have any recommendations I would be happy to troubleshoot it to figure out a solution to this.

Thanks,

Antoine

To add to this, I also tried reprogramming the cellular module with no luck there either

Seems only happens on some modules only, right?
have you tried to AT!NVBU and see if there is improvement?

@Antoine

So I have tried this on my unit and it seems ok (as per the below), as has been mentioned, is this consistent across all units?

ati
HL7802

OK
at+cgdcont?
+CGDCONT: 1,"IP","everywhere",,0,0,0,0,0,,0,,,,,

+CGDCONT: 2,"IPV4V6",,,0,0,0,0,0,,0,,,,,

OK
at+wppp?
+WPPP: 0,1,"",""
+WPPP: 0,2,"",""

OK

+CMTI: "ME",7

+CMTI: "ME",8
at+cgmr
HL7802.4.6.9.4

OK
at+ksrep=1
OK
at+cfun=1,1
OK

+CREG: 0


+CREG: 2

+WDSI: 0

+SIM: 0

+KSUP: 0

+CREG: 1
at+cgdcont?
+CGDCONT: 1,"IP","everywhere",,0,0,0,0,0,,0,,,,,

+CGDCONT: 2,"IPV4V6",,,0,0,0,0,0,,0,,,,,

OK
at+wppp?
+WPPP: 0,1,"",""
+WPPP: 0,2,"",""

OK

Regards

Matt

Hi @mlw @jyijyi,

The issue only happens on select few modules [the others will act like the example mlw posted above]. I’ve tried to use the non-volatile backup (NVBU) command with no luck there.

For some reason the affected modules just won’t save cgdcont to non-volatile memory. My biggest concern is that I now have a handful of modules acting in the same way.

Regards,

Antoine

Following up, I figured I would check to see if all non-volatile memory is failing to be saved.
I’m successfully able to change and save KSLEEP and KSREP values, so far CGDCONT is the only data that I’m having a hard time saving.

It took me longer than it should have, but I found the issue:

I imagine these units crashed or were rebooted during the bootup steps where settings are being configured in airplane mode. When they rebooted they were still in that state and I imagine the PDP context goes to a default state which is what I was seeing. I’m not sure why at+wppp returns an error in that case (I imagine that it’s due to the second configuration which is temporarily unloaded but can’t confirm).

I just went through my units and changed them to CFUN=1 and now they’re behaving normally!

Thanks,

Antoine