Open AT installation


#1

Have somebody succeded to install a new Open AT on a mashine which had a former version previously?

I assume the problem is with cygwin and erratic registry writing of the installer, but maybe i am little unskinfull. I’m going to try the newest Open AT soon, i hope the installation will not couse any problem.
Luckely, i have a lot of cumputer in my room without Open At.:slight_smile:

tom


#2

Yeah, I have had the same problem.
I’ve been using OpenAT 2.10 for quite a while and when trying to take the step to 3.02 on the same PC as previously had the 2.10, I failed.

Even though it looks like every trace of the previous installation is removed (including cygwin), it does not work. It seems like some PATHs are wrong. I tried to debug for some while then I installed it on a new “unspoiled” PC and it worked directly.

I gave up debugging, cause its too expensive to waste time on such a small thing as upgrading a software.

However, any clues to solve this are highly appreciated cause I hate to leave things unsolved.


#3

I agree, installing OAT 3.02 can be tricky-- I had many head-scratching moments while re-re-re-re-installing 3.02.

In my case, the problem had to do with the “passwd” and “groups” files created by Cygwin. My machine is part of a Windows domain, so when I log in, the password info is actually kept by the domain controller instead of the local machine.

Tomalex – uninstall the OAT package and delete the whole Cygwin folder, then reinstall. Post the errors you receive, maybe we can help.

Don


#4

I tried even to delete the entries related to Open At an cygwin in the registry, with no luck. I recall that one of the error was that no project file was created by the wizard, but everything seemed to be in order. And the other was a strange script error message.
I’m currently use Open At 3.01 (installed on open at free computer), and today i tried to install 3.02 on a mashine which had 2.1 before.
Strange, it went without a problem. :slight_smile:
I installed Open AT into the same path, and i used an other directory
for cygwin and it was a stand-alone computer.


#5

Tomalex:
Some more questions:

What OS and servicepacks is installed on the machine you sucessfully upgraded from 2.10 to 3.02?

Which version of Visual environment do you use?


#6

snoooze:

The computer has Win XP sp1, and visual c++ .NET 2003.
I did not use space in the Open AT and the cygwin path.

tom


#7

Hey All,

Also have a look at the post to the topic “Wmnew script error 3 (bad environment settings)” in this forum. When you open cycwin it should run several scripts to prepare your environment. These are stored in the .bashrc file in your user directory. If you are on a windows domain you may need to rename this to .bash_profile in order for it to run.

Have you run wmcheck to see what results it gives you?

Also make sure that you have administrator privaledges on your PC and all spyware / antivirus software that will prevent scripts running is disabled when you install. Beware that all of the directories created in the install are created with the installing user as the owner. Therefore you may have to change the permission settings on all of these directories if you would like to use the project wizard to create a project from any of the example source from a different user.

Kind regards,
Mike


#8

hi
I am new in using OPEN AT and i feel lost.
I am using fastrack supreme 20 and CGPS inside it.
Please tell me what i have to do to download a binary file on the modem.
i understood that i have to download open at sdk and make project but i didn’t understand from where exactly i should install it.
please give me clear steps.
thanks


#9

Hiya,

How is this related to this thread about having problems installing multiple versions of OpenAT?

If you have a new question, please start a new thread - don’t add to the end of threads that don’t really have anything to do with your question.

Please don’t cross-post the same question to multiple forums without linking between them - it only annoys people :confused:

ciao, Dave


#10

See: viewtopic.php?f=19&t=13&p=15454#p15454


#11

Hiya,

You beat me too it!

ciao, Dave