No Ack for I2C


#1

I am using m2m studio 1.0.2 with a development board q2687G and a fastrack supreme 20 (q2686G) also I have the R74 firmware on both and 06.30 OS on both.

I coded a application that works perfect on the development board but when I manufactured a board that fits onto the fastrack supreme I could not read any I2C data form the I2C ADC (AD7994UZ-0). There is I2C data going to the ADC but it is not Acknowledging back. I replaced the chip with a new one but still the same problem and the old chip was tested and worked with the DEV board.

More specs: I2C bus powered by CPU’s 2V8 with 2k2 resistors.

Can anyone please help me with this problem… :open_mouth:


#2

Does it work using the I2C on a Wavecom IESM?


#3

i know the I2C lines on the Q26xx dev-board are not populated, (no resistors etc),
i don’t know if that is the case on the fastrack?
can you measure the voltage levels of the I2C signals?
is your ADC a 3v3 part?


#4

Hi thanx for everyone’s help,

The problem was with the external switch mode PS, I did regulate the power before the chip, tried a few caps, but for a quick solution I just used a zener diode to chop of the power a bit. With my desktop PS i had no problem (regulated). :smiley: