New feature: Monitor multiple hardware units


#1

For testing, it is often useful - or even necessary - to have a (large) number of units all running and being monitored simultaneously on “soak” test.

Currently, the Serial Link Manager will not allow more than one instance on one PC; so such a test would require one PC per unit - which is unnecessarily and impractically expensive on PCs!

Therefore a way is needed to be able to monitor TRACEs from multiple hardware units on a single PC.

It would also be good if this did not require a complete installation of M2MStudio and the SDK, etc…


#2

Until Wavecom solve it, for 2 or 3 units you can run virtual machines and run an TMT on each one.
I’ve not tried it on Wavecom units but in other situations this solution has worked…


#3

Need logged. Actually, in the future, M2M Studio aims to become the central point of products development, including validation and testing.
And it indeed makes sense to be able to test/monitor several units at the same time.

Thanks for your input.


#4

I very strongly suspect that you would be disappointed!

I very strongly suspect that the Serial Link Manager would not be compatible with virtual machines…

I haven’t tried it either, so I can’t say for sure - but that is my gut feeling…

(A client was unable to use TMT in a virtual machine, but we never proved conclusively that it was the virtual machine that was the cause of the problem)


#5

i can say it is.
a colleague of mine is programming our q2686’s on a virtual machine on osx.
he does have troubles with stalling uploads though (VM->OSX->usb->serial related propably)


#6

I have used it on a WinXP virtual machine mounted on Ubuntu 8.04 and it had been working. I have had problems because it’s completely necesary that you use the correct drivers (if you use USB/RS232 adapter or PCMCIA) in Linux and also in Windows.
I have no experience with virtual machines on Windows working with physical ports, or some virtual machines running at the same time.


#7

ie, drag a text file from the Windows Explorer and just drop it onto M2MStudio to open it in an editor window.


#8

Actually, this is re-instatement of an old feature that has been lost from the v1 IDE! :frowning:

The v1 IDE had:* F3 = Open Declaration, and

  • Ctrl+F3 = Open Definition

M2MStudio has only F3 = Open Declaration - the Open Definition has been lost. :frowning:


#9

Before all, please just make a new post for every new suggestion, this will be more easy for traceability.

This is already working… Drag and drop a file into the editor area, and it will open the editor…

Actually, assuming that you are browsing code when a given function is called, and that you have somewhere in the workspace this function defined and implemented.

  • you can open the function implementation by “ctrl+clicking” in the editor, or hitting F3
  • you can look for function definition by right-clicking on the function > Declarations > Workspace/Project scope

#10

OK - see: viewtopic.php?f=78&t=3646
and: viewtopic.php?f=78&t=3647


#11

Example: viewtopic.php?f=78&t=3932&p=15442#p15435