MP70 firmware upgrade failed

I recently had an MP70 fail at one of our sites. We had a new one spare in our warehouse. I have grabbed the MP70 and found that it was not the LTE-A pro that we normally use. it is the MP70 , APAC, Wifi model. the Model number is 1102745. I logged into the web page and found that it had firmware version 4.6 and proceeded to download firmware version 4.15 from the website. I uploaded the firmware to the router and it failed. I closed the update window and continued to browse through the different menu options on the management page.
I needed to reboot the router to apply the new IP address and once it rebooted, it would not come up with the login page. I noticed that the lights were all red and could not do anything.
I was trying to login to https://192.168.13.31:9443. Nothing was showing.
I then tried http://192.168.13.31:9191 and it showed that it was in recovery mode and was asking for the file.
I downloaded the file from the website again, incase the file was corrupt and uploaded the second file.
I got the same error:
Installation failed. Please, retry.
Could not run swinstaller. Check that your package is compatible with the device
I have tried to contact support via the chat function and I had to fill in my details and all. I was told that I would be contacted via phone. I have not received any calls.

Any suggestions on what I could do to try and fix this please?

Hi @marco.daanunciacao ,
Because your firmware version is too old, please try upgrade to ALEOS 4.13 first.
If the issue still happens, please share with me the screenshot of the issue.

Thanks,

Hi Jerdung. Thank you for the reply. I would download 4.13, but I have no idea how to download the previous version of the firmware.
The Sierra web page only has firmware version 4.15 available. Please provide some guidance as to how I could get the previous versions of the firmware.
Thank you.

Hi @marco.daanunciacao ,
You can go to the link below to download:
https://source.sierrawireless.com/resources/airlink/amm/gateway-software-packages/#sthash.Su7Hlbtb.dpbs

Thanks,

1 Like

Awesome, that is what I needed. Needed to be upgraded in stages. thanks for that.