Mos_header


#1

Hi

When i try to compile my project i get an error “cannot find mos_header.o”
How do i create this ?

Best regards

Henrik


#2

Can you give details on how you have created your project?
Did you try just with a simple Hello_World sample project?


#3

Hi

I have tryed to make the Hello world sample.
Compiled Ok but when I try to download it from M2M it fails.

The Remote shell responds with.

at+wdwl
+WDWL: 0
*** ERROR IN HEADER ***
at
OK
at+cfun=ý
OK


#4

Are you sure the SDK/Software Suite profile you are using for your project is compatible with the wcpu you are using (and also compatible with the Firmware version currently running on the target)?


#5

Correct - that was the problem.


#6

Hello,

Im having the same errror message. I have a Fastrack Supreme Wavecom modem with an AT V4.20 and firmware Version 6.63.

Which is the correct project profile for my device? Also, where can I download it or find it?

Best regards.


#7

Such compatibility topics should be posted on other forums than this M2M Studio dedicated one…
However, to help you, you have to download an SDK compatible with your hardware.

  • Go to wavecom.com
  • Log in
  • Go to products > Fastrack Supreme
  • Go to Downloads > Archive
  • Grab the last Open AT SDK v4.2*
  • Don’t execute the exe file, but import packages in M2M Studio (File > Import > M2M Studio > Packages from IDE V1 > Browse to the exe file)
  • Make your project use this profile configuration… (Project Properties > Open AT Application)