Missing QMI calls + Location in EM7565?


#1

Accessing a new sample EM7565, through Windows, using latest drivers from The Source, accessing via QMI. Firmware version appears to be “SWI9X50C_01.00.02.00 6ff48a jenkins 2017/09/29 05:54:26”. This is early testing to try and get a jump on things before these units start showing up from the laptop vendors & our customers are bugging us.

I cannot make the DMSGetICCID (svc 2, msg 0x3c) or DMSGetIMSI (svc 2, msg 0x43) calls succesfully on the EM7565. Returns Gobi Status 1094 for both… which appears to translate to eQMIErrors_NotSupported.

Are these truly unsupported calls now? Granted I’m working off a QMI spec from 2012, but still… If I switch to collecting data through Windows Mobile Broadband, I am able to get both the ICCID and IMSI correctly.

Likewise, on this particular device, I cannot get any location data, either through the Sierra Windows Location Sensor provided by the driver bundle, or through the exposed NMEA port. It seems like occasionally the NMEA port wakes up and sends some bogus NMEA data for a few seconds and then stops.

Calls into the QMI PDS to set the service seem to be failing with Gobi Status 8 (eGOBI_ERR_NO_CONNECTION).

Any insight would be greatly appreciated!


#2

The latest available Firmware is

SWI9X50C_01.05.01.00 7772ee jenkins 2018/02/23 18:02:17

I don’t know if it fixes the problem though.


#3

Found the new firmware shortly after posting - thanks. Tried it.

Still getting same result on ICCID/IMSI calls, i.e., no result.

I have still not gotten a valid location, but I did notice with the new firmware, the Sierra Windows Location Sensor now pops into “Initializing” state after plug-and-play detection of the device, where it previously always stayed in “Not Available”. Not ruling out a hardware / antenna issue on my end, as this seems “closer”.


#4

Hi,

EM7565 doesn’t support voice call.

Regards,
Kush


#5

Have you even read the opening post?


#6

Call in this case = A function call in a programming language.


#7

All SIM-related operations from the DMS service are deprecated in newer devices, starting from the MC74xxx series. My guess is that these modules support multiple SIMs at the same time, and the SIM-related DMS interfaces explicitly work with a single SIM card. In order to get SIM related information in these new devices, you should use the much more detailed UIM service, which is prepared to work with multiple SIMs.


#8

Thank you for the pointer Aleksander. This also sounds like it might be the same root cause of the other two posts seen in the last couple weeks (AT command to get IMSI/ICCID doesn’t work, Linux QMI commands to get IMSI/ICCID dosn’t work).

Now I just have to learn a whole new slew of acronyms. MF, EF, DF, ADF, etc… :exploding_head: