MC8704 under Linux


#1

Hi, all

I am trying to get MC8704 card to work with Linux. So far I tried on few different platforms (PC with UBUNTU 10.04 and 11.04), custom ARM board running 2.6.32 kernel, ALIX board (embedded x86) running 2.6.38 kernel. All platforms exhibit same fault:
Device is found, enumerated, then disconnected. As far as I understand, certain interfaces are “blacklisted” by sierra USB serial driver and DirectIP driver (sierra_net) should take over. Well, I built the module for sierra_net and installed it. Problem is same except I also get the error:
Error in usbnet_get_endpoints (-62)
So, looks like sierra_net is not working very well with this card. Card itself is OK, as it works on Windows machine.
Did anyone got that card to work successfully under Linux? Any tips?

Thanks,
Rudolf
P.S. At the moment I tried to delete the blacklisted interfaces from sierra serial driver, but still have same problem – device connects, enumerates and disconnects.


#2

In answer to my own question – I fixed the problem by upgrading firmware on the MC8704 to T2_0_2.

Now, for some reason, network device does not appear as it should, so more work is needed. But, at least modem stays up and I have AT command access to it.

Rudolf


#3

Hi,

Hope it is not too late.
Can you share the Linux log for USB enumeration and the PID used causing no network interface?

L