MC8305 Windows 8.1 Compatibility


Wondered whether anyone has had any issues with getting the MC8305 drivers to install on Windows 8.1 Professional?

We’ve got a Panasonic Toughbook CF-19 Mk 7 Toughbook, which contains an MC8305 modem. This is listed under Network Adapters by the O/S simply as MC8305; and it installs a generic Microsoft driver, vwifibus.sys. There’s nothing listed under modems or ports related to Sierra Wireless

I’ve tried the drivers available on the Panasonic website; according to the .inf file and the hardware IDs displayed for the device, these are compatible, but will not install. If forced, the unit stops being recognised at all by the operating system.

I understand (both from web searches and looking at the card itself) that the MC8305 and MC8355 may be related; with this in mind I’ve tried installing MC8355 drivers from the Panasonic website too. While these appear to install successfully, and create the expected Sierra Wireless Modem, Sierra Wireless Broadband adapter and Sierra Wireless DM / NMEA ports, following a reboot these are marked as not connected. The O/S then picks up the MC8305 devices and reinstalls the drivers, constantly … ended up with over 100 COM ports for DM / NMEA and 40+ instances of the modem and broadband adapter before I uninstalled the drivers.

The Watcher install provided with the unit does not install any drivers, although it does appear to see the modem. It also reports that the modem is a “QMI”, so would’ve thought that the Sierra Wireless QMI package would work.

I’ve reported to Panasonic but have not yet received a response; have discovered other Windows 8.1 driver support issues so not sure what response I’ll receive.

Has anyone come across this (or similar) and managed to establish a workaround?

Any advice gratefully received …


Yes, QMI drivers should work for MC8305…

could you provide me the link from where you installed the drivers… the QMI drivers?


Thanks for the response. I tried the drivers Panasonic provided, which can be found here. Admittedly these say that they are for Windows 8, not 8.1; but Panasonic’s documentation indicates that these should be used on a clean install of Windows 8.1

As indicated, as the physical card also had “MC8355” printed on it, I also tried those drivers from the Panasonic website, which can be found here and here. Panasonic’s support have since told me those can brick the card, so seems I was lucky …

Please let me know if you need anything further from me


I should probably also advise I’ve since discovered that if I extract the drivers from SWIQMIGobi3kSetup.exe as provided in the first link, and incorporate them into the install.wim of the Windows 8.1 Professional installation media then carry out a clean install, the card will pick them up, apply them and appear to be stable with all functionality.

However, if we then try the installer on a Windows 8.1 clean install built from that media, the Sierra WWAN modem, Wireless Broadband Network Adapter, DM and NMEA ports are all disconnected and hidden (Code 45, device not connected in Device Manager); and the MC8305 network adapter using the vwifibus.sys generic Microsoft driver is reinstated

Just wondered if anyone else has encountered this issue, or if the Sierra developers have come across it anywhere else?

I’ve noticed now it’s not just Panasonic Toughbook CF-19 Mk VII units that are affected; we’re also seeing the same issue with Dell Venue 11 7130 tablets (although Dell refer to it as Dell Wireless 5570e, so not sure if it refers to exactly the same Sierra Wireless chip)

Now discovering exactly the same issue on a Dell Latitude 14 5404 Rugged laptop. Any update regarding the issues, please?

Really, no-one else has noticed this issue in six months … ?

Can consider this one closed now. Found this on the Dell support website, pertaining to the Dell Latitude 14 5404’s Wireless 5809e LTE modem driver (which uses the Sierra Wireless chip):

“For Win 8.1, Microsoft Inbox driver is installed to Mobile Broadband card by design, it still requires to install Dell driver package to enable Mobile Broadband function and GPS driver [sic]”

So after all these months, it appears it’s supposed to do that … surprised no-one on here appeared to know that or was able to advise, though … ?