[MC8090]How to use UART as AT Command


I’m facing one problem about UART control of AT Command with MC deb board and MC8090.

I changed MAPUART settings to set AT Command from UART.
Before change it, I set +IPR and $QCTER to 115200.

And then, I tried to type AT command from UART1 connector(CN11)
but MC8090 never response it, such as local echo or any response.
I think board DIP switch is correct.
(Please see attached file)

I need your help to type AT Command in UART or back to default setting to type it to USB.

Thank you.



Use +WHCNF command to enable the UART.



I can’t send any AT command to the module
because USB AT command port is not available now since I have already entered !MAPUART=1.

Thank you.


Use the USB MODEM port to send another AT!MAPUART to map it back to the original state.

Most AT commands on the modem port replies OK without doing anything, but !MAPUART works.

Had the same problem on SL8090 once.


I got it!

Thank you for your help.


I can get back to the setting by modem port.

Then, I’d like to send AT command through UART in MC devboard.
Currently, +WHCNF? and +IPR?return is follows.

+WHCNF: 1,0,0
+WHCNF: 6,1,0,0,0,0,0,0
+WHCNF: 7,0,0

+IPR: 115200

It means UART was enabled and baud-rate is 115200.

Then, I send command to UART with 115200 baud-rate settings but AT command port never response.

I need the help to send AT command via UART.

Thank you.