MC77xx GPS fix

Has anybody gotten a 3D fix (GPGSA message A,3) from the GPS? Even with 8 satellites and a DOP dilution of 1.0, the messages are still coming in as A,2 (2D Fix). With the DOP of 1.0 or less and that many satellites in view, the fix should be 3D.

What firmware are you using? What mode (QMI or DIP)? I have gotten 3d fixes on my mc7700 QMI Do you use MS-Based or MS-assisted GPS? You should try standalone mode and see if you really get 8 satellites. Also do you have gpsonextra enabled? Do you have GPS antenna connected to the GPS antenna port or do you use the diversity antenna port for GPS?

3 different cards (all MC7700), all firmware and also, all in QMI mode. I have never used MS-anything on the device, always been standalone. GPSOnextra is enabled, SUPL is set. Tried both the diversity port (port 2) and also standalone with external GPS antenna and wideband patch (TAOGlas).

Yep, it actually gets 8 sats, both GPS and GLONASS. I can watch the sat data, DOP, etc. It’s all great, except for the GPGSA message still reports a “2” in the fix type position. Never gets a 3…

Are you sure you are actually getting 3D fixes? Does the NMEA sentence for GSA look like this:
where the 3 position is actually a 3? (1=no fix, 2=2D, 3=3D)

I will check whether I truly get 3D and get back to you. Member lotam mentioned the existence of a firmware, with GPS improvements, in my other thread. I have no FAE or distributor so if you or someone can access this firmware and make it available it would be great. It may help with this problem too.

Hello, the visual gps utility reports long, lat and altitude so that seems 3D to me. Although the altitude is off as I do not think I am at 900ft. The GPGSA sentence always has a 2 in the position you mentioned though. See the attached NMEA output from my MC7700. So perhaps you are right and it is yet another bug. Let’s all ask for the latest firmware to see if that clears up the gpsonextra and 3d fix problems.
nmea.txt (7.09 KB)

I used to have an FAE, when I was deving on the MC8790, but with the new systems which are coming with an MC7700, I don’t think that he’ll support me on this since I didn’t buy the card from them.

That would be nice, especially if it fixes the GPS bugs. I too, use the visual GPS util and it does report something like 22 visible sats, 8-10 active, mix of GPS and GLONASS. After 60+ mins of receiving good data, with good signal on all sats, the fix should kick to 3D and be clean.

I think I may have found another bug…changed the bitmask so that only “pure” NMEA sentences are outputted (no $p proprietary lines), but the $PQFXI sentences still appear. Leaving that 5th bit out should have disabled those sentences. Try setting AT!GPSNMEASENTENCE=1DF and see if you can get rid of the $PQFXI sentences if you get a chance.

Set/report NMEA sentence type
Set or report the current GPS NMEA sentence types.
Response: OK
Purpose: Enable or disable NMEA sentence types.
Purpose: Indicate the currently enabled GPS NMEA sentence types.
Purpose: Return valid parameter values.
(NMEA sentence types)
• 2-byte hex format mask (Note: In the execution format, do not include ‘0x’
before the mask value)
• Each bit: 0=Disabled; 1=Enabled
• Bit 0: GGA (Fix information)
• Bit 1: RMC (Recommended minimum data for GPS)
• Bit 2: GSV (Detailed satellite data)
• Bit 3: GSA (Overall satellite data)
• Bit 4: VTG (Vector track and speed over the ground)
• Bit 5: PQXFI (Proprietary Qualcomm eXtended Fix Information)
• Bit 8: GNGNS (Time, position, and fixed related data for GLONASS receiver)
• Bit 13: PSTIS (GPS session start indication)

You are right. I tried and could not get rid of the $PQFXI sentences.

@lotam, could you weigh in? Forum posts like this are valuable feedback on the AirPrime cards from knowledgeable users and can help you to make the products better if you act on it. It would be great if you could make the latest firmware available and comment on specific issues raised (perhaps some of these are known issues or recently-addressed issues?). Thank you.

Definitely agree here…the issue is that back in the day, we had to purchase our cards separate from systems and hence, the FAE for help. But, nowadays, most of the hardware we are receiving already has the MCxx units preloaded. So, since we didn’t just purchase the card alone from a distributor, we don’t get that FAE benefit.

But, we are still having to develop apps and support the platforms that use the hardware. Which, I’d guess, is why we’re here on this developer forum. The problem that I’m finding is that there are end-user support sites which have newer revisions and tools than what’s available here to us. I think the NDA we all had to sign when we first worked with the cards is what is holding up the users who still have access to an FAE from posting those firmwares here. We pretty much have to get somebody to “approve” the release of that FW or we’re just stuck at where we are. Pain is, if my company gets stuck here, they’ll just drop all of the MC cards and go to another vendor which will provide support for custom apps. And, that means re-writing all the code from ground up again…

I’m assuming my NDA’s still valid from when I had access to the Sharepoint site, which was a great resource to use developers. However, that site’s been closed and we are all directed here now. So, since my NDA should still be good, how about somebody sending me that firmware!

It would definitely be great if we could get the newest firmware to see if this GPS issue gets resolved. With all of the units that we are having to support AND write custom apps for, we are kinda at a standstill until we get the GPS issues resolved as user position is one of the keystones of the app’s purpose.

I love how it’s been a week since this has been up and it’s been nothing but crickets around here. Even though there’s a “possible” firmware fix, but it’s not available to those of us who don’t/use to/may still have a FAE, and it’s obviously an issue with the card, not a word from any SW personnel.

New topics have been posted, and answered. But, this unresolved issue still sits around with not-a-comment.

Every other “developer” board I’m on seems to focus on one thing: getting the fixes and tools so that developers can work. Which, in turn, gets more sales of a product.

However, I’ve noticed that SW hasn’t ever really been helpful and unlike the old Sharepoint site which actually had useful tools and FW, this new “developer forum” is much less useful.

NOTE TO SW: Unlike the old’en days where nothing came with WWAN cards and everybody who worked with it bought the cards from a distributor with an FAE on staff, most of us are now working with off-the-shelf systems that have the cards pre-installed from the system manufacturer. And, I thought the whole purpose of this forum was so that developers could get support when working with your product…

…Chirp, chirp, chirp

I just sent an email to reseller perhaps they can give us the firmware to try. I have trouble understanding why the employees on this forum, such as lotam, are unwilling to be of any help. :mrgreen:

Well, the lack of any response seems to speak volumes on how much SW actually cares about developers trying to work on apps for their products…or that bugs exist in their firmware.

Guess it answers the question on what hardware to (not) use in the future!

I share your wish for an even more open dialogue between hardware vendors and software developers, but I find that comment extremely unfair. There is of course plenty of room for improvements, but Sierra Wireless is still best in class in my opinion.

Show me another vendor with

  • an open forum like this one
  • employees participating in the forum
  • firmware updates available to all developers
  • documentation available to all developers

Firmware release procedures are likely restricted in many more ways than we can imagine.
Please give them the benefit of doubt.

Actually, it’s quite fair. Giving that the original posting and request was 2 weeks ago, and that nobody has even responded, I’d say that the time period alone justifies the comment. As a developer, I understand that there are always room for improvments. However, all that it takes is a simple “hi, we are working on it, stay tuned” to indicate that one has acknowledged the message.

On top of that, guho and I seemed to be the only two that were talking. For an “open” forum where “employees” participate, not a single one attempted to enter the conversation and offer any advice.

We see from our other conversation that there is a newer “” firmware. For such an “open” forum, where is it? Like I said before, back in the day where the firmware was uploaded to the Sharepoint site, we could access it and give it a try. As guho said back on the 23rd, we wonder why no SW employee/member/etc has posted anything on our conversation, even though we noticed them posting on other messages.

BTW, yes, I was a developer then (during the Sharepoint days), AND I had a FAE. I had also signed the NDA, which should still be valid. However, since nowadays we don’t necessarily NEED to buy the modems individually, as many computers/tablets include them in the OEM spec, the idea that we would “need to speak to an FAE” to get the newest firmware, even if it’s beta, is ridiculous. And, also to expect that companies would specifically go out to an FAE supported company to specifically buy a device when the new (beta testing) laptops for our software includes the same device when purchased.

All that is needed is to post the firmware with a “warning: beta. May brick your device. Use at own risk.” and things would have been fine. However, also as a developer, I can understand that it’s probably because it’s beta and nobody wants to support a bunch of bricked devices, so a simple “it’s in beta, will post when tested a bit further” would have been acceptable. BUT, there are other posts where users are advised to go and try the (or newer) firmware, so it’ can’t be because it’s beta and unstable, now can it?

Another vendor with an “open forum”, “employees participating”, “updates available”, and “documentation available”? Try Microsoft/MSDN, Corsair (there’s much “in testing” firmware), and Pocketwizard (I’m a photographer also). There’s many more, but that’s not the point here. It’s the fact that the only postings were between me and guho, both of us mentioning trying a process and finding the same bug, and attempting to get the newest firmware which may have already addressed the issue. That, and both of us attempting to contact an FAE and getting no response (not the FAE’s fault, as we didn’t buy the product directly from them), which is the reason we posted here in the FIRST PLACE to attempt to get access to the firmware or some idea of how to do such since this is the SW “developer board”.

I’d say at this point to show me a company where management will allow a developer to continue working on applications that target a specific device when the developer is stuck at a possible manufacturer’s bug and the manufacturer isn’t responding with support. They’d either kill the project or change vendors.

Yes, their hardware is “best in class”, when it’s working. However, you wouldn’t keep driving a Ferrari if it was slipping in gear, would you? I’d try to get it fixed, and if nobody was willing to even look at it because I didn’t buy it from them or hell, even bother to look at it at all, I’d probably go get something else like a Volvo where I’d get a response like “we’ll look at it, even though it may not be under warranty, you ok with that?”.

I might add we are still using our supply of MC8790 modules. The FAE mentioned in email that there was newer firmware than we are using that might have “fixed our problems” and I requested it. Crickets for me too, so even having an FAE from the vendor from which you bought your modules doesn’t seem to work anymore if you aren’t perched to be buying more ASAP. It’s a money game.

Oh and a huge amount of the commands etc. are “standardized”, so as we found out, it appears that you don’t necessarily have to re-write as much code as you thought to go with another vendor if that is necessary. We haven’t gone down that road yet, and now we are closing our doors anyways, so it’s a moot point.

PS: Our software would filter out the fix if there was never a 3D fix reported, as that is one of our “flags” we use to determine if the reported location is reliable enough to be used, so that firmware bug would make the modules essentially useless to us.

PPS: I’ve discovered in the 8790 that if I turn on A-GPS by setting gpsautostart to have 2 in the second field, then Xtra won’t download the data. SUPL doesn’t provide constellation data apparently and is only used for A-GPS it would seem, so the GPS goes back to being “blind” on startup. If I had a chance to go back and re-do our setup, I would start the GPS in standalone, let it get the Xtra updates for constellation and ephemeris and then switch to A-GPS to potentially improve the fixes. I don’t know if that’s true in newer firmware.