I bought a mc7750 from amazon that is tagged Lenovo. I loaded vzmanager and it does not see the card. I finally got drivers to load and device manager sees 4 different things but they are all code 10 cannot start. this is a home build pc any ideas? Please help

What you mean by this???
Are you using the correct drivers? Can you share screenshot of your device manager?


I have nearly the same issue going on. I have a CF-31. I’ve unlocked the bios WWAN. And windows can “see” the card, but it isn’t taking drivers. When I disable, and then re-enable the WWAN in the bios, windows detects the following.

USB Composite

I have tried installing the drivers from Panasonic. And the drivers from Sierra Wireless, both the 4743 build, and the 4277 build. With each install, I’ve uninstalled any previous drivers, and removed the devices from the device manager.

I thought perhaps it was conflicting with some serial devices I had on different COM ports, but even after disabling them, I saw no changes.

Any advice on where to go from here would be greatly appreciated?


I believe you should specify which Lenovo model and OS ? Because not all Lenovo models are compatible with MC7750. I’ve EM/MC7455 and MC7304 where only MC7304 and EM7455 are compatible (internally) with Lenovo X220/X220T whilst got problem with MC7455 even though installed externally (via mPCIE to USB converter). if “Code 10” that means that device couldn’t be started (normally). You can install latest Sierra QMI drivers for the related devices.

Of course, I’m sorry I overlooked that.

I am trying to install this in a Panasonic CF-31 mk1. All of my research says that it is compatible. I did have a bit of trouble getting my bios to even see the device, but after reading through a different post I found out how to enable it.

Once enabled, I got to where I am now with 4 MC7750 devices in the “Other devices” category of the device manager. And a USB composite device that is listed as working.

My OS is Windows 7 64bit.

Another thought: I am beginning to suspect that hardware is fine, but the firmware would need to be updated with firmware from Panasonic before it will work…

I am in a similar situation, but with a CF-19. Windows 7 detects the card, but I only see the 4 MC7750’s under Other Devices.

Has anyone had success with this?

My CF-19 had a factory- installed MC7750 that stopped working. Was trying to replace it with an MC7750 that has a Lenovo part number on it.


That MC7750 (factory installed) for that model is actually recognized by that hardware but missing drivers. Have you tried installed “USB Drivers Build 4431” from Sierra website. Believe should be ok. You cannot use MC7750 (for lenovo) because is configured for lenovo instead of CF-19, but can be configured back to be used as “generic” with so much steps.