MC7710 dualstack


I’m trying to connect dual-stack apn with MC7710 in DIP mode (with IPV6 features enabled). I sucessfully setup profile by command at+cgdcont=4,“IPV4V6”,“gprst.ipv6” and I established connection via command at!scact=1,4. Everything looks fine but only one IPV4 PDP context is established (I see this on GGSN). I tryed same thing from Sony Xperia Z and it working correctly (2PDP’s, one IPV4 and one IPV6). Is there anyone who sucessfully established functional dual-stack ? Thank you.


Which FW is running on your MC7710?

Also, which host you used for testing?
Does the host and USB driver used support IPv6?


It might be necessary to enable IPv6. First check status:

If the last command returns 0 run:


I’m using latest fw (DIP) from sierra and this driver for linux: … spx?aid=44

@lotam: I’m using Centos 6.5 x64 linux host (Lenovo T410) with ipv6 driver support.
@krima919: IPV6 features is already enabled in the past (without this I’cant establish any IPV6 connection)

I can etablish pure only IPV6 connection and also pure IPV4 connection, but I can’t connect with dualstack (simultaneous IPV4+IPV6) configuration.
Is there anyone who are using dualstack on MC77xx modem?

Thank you.

The culprit is the LSI (Link Status Indicator) handling in sierra_net.c. DS contexts trigger a LSI which is slightly different from the current single stack LSIs. This LSI is not documented in the most recent HIP/CnS documentation (assuming you are using DirectIP, not QMI mode), so I had to guess its format (hint: its very similar to the current format, and you only need the indication itself, not its contents. The Link Down LSI is the same for single and dual stack).

Could you please submit a patch against the mainline sierra_net.c driver with this change? I believe it would be good to have it there, even if we cannot easily update the version on the sierrawireless website.

I have attached a patch, which is not even compile tested. Might work, nevertheless …
sierra_lsi_ds.txt (5.4 KB)

Thank you. I will try the patch. Where the patches can be downloaded ? Is it some git exists?


I tested the patch. There was some mistakes in code but I corrected it. Dualstack still not working.



I’m still not able connect with dualstack. Any other ideas or new patches?

Thank you.



First of all, sorry for digging up this one year old topic : I’m facing the exact same problem.
I adapted the patch @stefanbruens gave.
DHCP is working, I’m able to get info about IPv6 with AT commands but no RA are coming. (Though there are some parameters passed into the LSI structure.

Maybe something to add within the “lsi_umts_ds” structure ? Any documentation maybe ?

Any help is welcome !
Thanks in advance

This “Link Status Indication” message is documented in “2130602 CnS Reference” which I believe you’ll find somwhere on the “source” website. You could also tweak the driver to dump the whole message so that you can inspect it. Or just snoop it, using usbmon. The IPv6 address info will be obvious if present.

I could not download your attachment for some reason (“The selected attachment does not exist anymore.”), but the current driver as it is in the Linux kernel does not parse the address information contained in these messages. I believe an early version of the driver parsed it and used it for an in-driver DHCP server or something like that, but this was not accepted when the driver was mainlined.

For IPv6 support you’ll probably have to parse the LSI and make “something” use the address info, assuming that the firmware doesn’t implement any RA or DHCPv6 daemon. Which I doubt it does in DirectIP mode.

Sorry for the late response,
I looked up the reference and many commands,

Finally,I took some time to patch the latest driver (v3.2 from Sierra instead of the v2.0 in kernel).
And it’s working, I get Router Advertisement and DHCPv4.
It seems I have to up the interface before doing the AT command though.
I’ll try to publish asap.

Thanks a lot.


Could you please publish the mentioned patch? Thanks.

Don’t know anything about the patch in question, but did you try the mainline driver after this patch was commited?: … 6befed1c2d

It was first introduced in Linux v4.10.