MC7700 succefully connected to GSM/WCDMA! Need LTE...


We are running the latest linux ubuntu version. We have successfully connected with several non-LTE technologies. We are using AT commands to communicate with the modem. For example the normal process of connecting to the internet that we have been using (AT commands) is:

    this checks a bunch of information regarding connection. When the computer boots and all our settings are good, we are able to connect to the internet automatically.

    so far, we have been using n = 5, 6, and 7 (“GSM and UMTS Only”, “LTE Only”, and “GSM, UMTS, LTE”, respectively). Only 5 and 7 have been able to connect to the internet. When 6 is selected (“LTE Only”) we have tried everything but with no success.

  3. AT!SCPROF=,"",1,0,0,0
    our pid is set up as:
    AT+CGDCONT=,“IP”,“Broadband”, since we are using AT&T

  4. AT!SCACT=1,
    this is one of the problematic steps when using “LTE only”. it has worked in the past but it is not working any more.

  5. AT+CGATT=1
    this one almost never works in “LTE only” mode.

These are the steps we take to get internet connectivity with the non-LTE technologies. We are wondering what additional steps or settings we have to change in order to connect to LTE. Any help is appreciated.



Check for BAND setting using AT!BAND command.