[MC7700][AT Command]How to set multiple APN in MC7700


#1

[Platform]Linux
[FW version]03.05.19.00A
[QMI Driver Version]S2.11N2.17
[SDK Version]SLQS03.01.03

How do you set multiple APN in MC7700?
Currently, MC7700 can activate APN that is only cid#1.

Please see following is my test result.

1st test setting CID#1 : mopera.net CID#2 : pre4657.xi.dcm.ne.jp

2nd test setting(cid# switching)
CID#1 : pre4657.xi.dcm.ne.jp
CID#2 : mopera.net

*Of course, a SIM that we are using as test supports both APN.

I.Send AT Command as follows ・at+cgdcont=1,"IP","mopera.net" ・at+cgdcont=2,"IP","pre4657.xi.dcm.ne.jp" ・at!reset II.★After the module power on, Activate CID#1 APN by Connection Manager that is one of QMI SDK Sample Application. III.Finish SDK and the module is reset by AT!RESET IV.★After the module power on, Activate CID#2 APN by Connection Manager that is one of QMI SDK Sample Application. V.Finish SDK and the module is reset by AT!RESET VI.Send AT Command as follows(Switch CID#) ・at+cgdcont=1,"IP"," pre4657.xi.dcm.ne.jp " ・at+cgdcont=2,"IP"," mopera.net" ・at!reset VII.★After the module power on, Activate CID#1 APN by Connection Manager that is one of QMI SDK Sample Application. VIII.Finish SDK and the module is reset by AT!RESET IX.★After the module power on, Activate CID#2 APN by Connection Manager that is one of QMI SDK Sample Application. X.Finish SDK and the module is reset by AT!RESET XI.Check test result at ★

II★After the module power on, Activate CID#1 APN by Connection Manager that is one of QMI SDK Sample Application.

LTE Data Session started successfully

IV.★After the module power on, Activate CID#2 APN by Connection Manager that is one of QMI SDK Sample Application.

Failed to start LTE/CDMA Data SessionFailure Code : 1014(0x03f6)
WDS Call End Reason : 1016(0x03f8)

VII.★After the module power on, Activate CID#1 APN by Connection Manager that is one of QMI SDK Sample Application.

LTE Data Session started successfully

IX.★After the module power on, Activate CID#2 APN by Connection Manager that is one of QMI SDK Sample Application.

Failed to start LTE/CDMA Data SessionFailure Code : 1014(0x03f6)
WDS Call End Reason : 1016(0x03f8)

Thank you.

–Takuya


#2

Hi,

Could not find the same behaviour. Was able to activate 2nd context id successfully (SIM card supports only one APN).

Just to confirm, could you test with a SIM card supporting only 1 APN and activating the Context ID 2?

Thanks


#3

Dear kagakuka,

I see you are also using SDK, which I am trying to use also, but have some troubles
starting it. I have described them here:
[url]https://forum.sierrawireless.com/t/starting-slqssdk-with-mc7710/6732/1]

I am using version SLQS03.00.02 on ARM platform and when I start it,
I only get Cannot find device…

Did you try running Connection Manager in sample application?

I also tried running it on my Desktop PC, but with the same results.

Thank you and Regards,
Matej