MC7455 cycling on and off in Mikrotik RB922UAGS-5HPacD-US

I have a Mikrotik routerboard RB922UAGS-5HPacD-US running ROS 7 (tried multiple versions) with an MC7455 running firmware version At first the modem module didn’t show up at all in the Mikrotik router. After reading somewhere that I needed to tape off pins 23,25 and 31,33 it shows up now. However, it only stays connected for a few seconds and then the modem module goes away for a few seconds and comes back. I can see that it connects to the internet, gets an IP address and DNS addresses but then drops. Has anybody experienced this problem or have any ideas of what else i can try?


I am pretty green at this stuff,but have done a lot of reading and trying at commands on the EM7455,the M.2 version of what you have. My suggestion would be to see, is use a serial terminal connected to the modem,if you can connect from a windows machine Putty is a good serial client, keep it connected see if there is any odd stuff,looking in terminal,If you have never done this before,you don’t really know what is ‘normal’ though,is the down side.

Also,have you tried a second power supply to your router…
Did you physically pul the modem from socket make double sure,you dont have a contact that got gouged off tape into socket?