MC7355 is changing manually set IP settings

I am having an issue with some Sierra Wireless MC755 modems.

These have Verizon SIM cards in them and previously had static public IP’s from Verizon. We recently transitioned to a VPN so I need to assign private IP’s to these modems as our VPN address pool is static. The problems that I am having are:

  1. The network settings in Network and sharing center are blank. Even if I set them to manual, enter my information, leave and come back, they will be blank. The DNS server settings stay though.
  2. the IP address and name servers will stick but something is changing the subnet mask and gateway.

So, say I set the following IP settings on the settings on the ‘Cellular 2’ connection, ipv4, ‘Use the following IP Address’:

IP:, Subnet:, Gateway

If I then run ipconfig I will see that IP address and name servers stay but the net mask will always, no matter what I do, change to and the gateway will always, no matter what I do change to one IP above whatever was set as the IP address. So, for example, if I set the IP to the gateway will be

it doesn’t matter what IP I use in any range this will always happen.

Here are some examples to hopefully clear up what I am talking about:

I manually set IP:, Netmask:, Gateway:
Ipconfig will show: IP:, Netmask:, Gateway:

I manually set IP:, Netmask:, Gateway:
Ipconfig will show: IP:, Netmask:, Gateway:

Etc, etc, no matter what I do. As stated in (1) above, every time I go into the adapter settings to change the IP settings the IP address, Subnet mask and Default gateway fields are blank even though ‘Use the following IP address’ is still selected.

Verizon is claiming that this is something the MC7355 firmware is doing. Hopefully someone on here will have an idea of why this is happening an maybe something I can do to fix it? Are there some AT commands I can use to set these on the modem itself or to tell the modem to stop changing these settings and use the settings I enter into the IP configuration of the adapter?

Thank You


“but something is changing the subnet mask and gateway.”

The netmask and GW are created by the modem, those cannot be changed.

Your script is calling dhcp and the modem transfers the GW and netmask over dhcp.

Or you application may use QMI.

Do not use DHCP and modem manager. Just manually set the IP.



Thank you for the response. I am not using DHCP. I am setting IP settings manually through the normal windows IP configuration settings. No matter what I set, the Gateway and netmask are being changed per the original post.

I’m not sure what you mean by “Your script is calling dhcp and the modem transfers the GW and netmask over dhcp” I’m not using any scripts nor am I using DHCP. I am also not using Modem Manager.

I only have the Generic firmware and drivers installed and nothing else. I am simply trying to set the IP settings through the normal windows network settings.

On a side note: Everything seems to be working so maybe this is a moot issue? I’ve just never seen an adpater do this before and by all conventional network rules it should not work since the Netmask and gateway, according to ipconfig are wrong. Please let me know if you need anything cleared up. I can provide screenshots as well if it would make things more clear.

Thank you again for your response.

Never mind, I thought you were using Linux…
The NTWK is only sending the IP , and the modem creates the GW & netmask based on an algorithm in the FW.
Windows must do some magic in the background and transfers the GW and netmasks over from the modem.

No worries, I appreciate the info.

This makes sense, If it always sets the netmask to /30 then technically whichever IP wasn’t the IP address would be the gateway since there are only 2 to choose from.

Again, it seems to be working so far this way but just in case I have problems going forward (i’ll have a bunch of this and I don’t want one to think its gateway is an IP assigned to the next unit in line) is there any way to make the modem stop or to specify what I want the netmask to be or tell it I want /24 masks?

Worst case I can just skip /30 blocks. I don’t think I have enough units for this to be an issue but it would be nice if the modem would respect my settings but I do understand that cell modems of this nature aren’t typically used on regular private networks.

Thanks again for the help.

unfortunately you cannot