[MC7350 Sprint] No transition from weak LTE to CDMA

On field testing in US, modem keeps LTE in weak LTE signal area. On modem status, I could see RRC idle and Low power mode. Never goes to CDMA.
At this moment, I tried AT+CFUN=0 and +CFUN=1 but modem status is same.
Also, after modem reboot and attached LTE, I tried ping -t x.x.x.x for not going Low power mode, but result is same, RRC idle and Low power mode.
Finaly, after I manually set CDMA only and reboot, modem successfully attached to CDMA, and No RRC idle or Low power mode.
Also this means CDMA signal is strong.
Would you please give any information, how to handle this issue? New firmware software?
Is there any command that not going RRC idle or Low power mode? Endless Ping doesn’t work.
Current modem firmware is “SWI9X15C_05.05.63.01 r28860 CARMD-EV-FRMWR1 2015/07/02 11:04:50”.

Still, it’s not clear that this issue is occurred only on one specific modem or not.


For recovering this kind of issue, in case of ‘LTE attached && RRC_IDLE’, AT+CFUN=0 and +CFUN=1 is implemented on source code,
but AT commands don’t work on modem at some point (RRC_IDLE, and Low Power Mode).
The only way for normal LTE operation is reboot modem.

Still, trying to find solution…

Self answering… :confused:

A modem itself doesn’t support Automatic RAT chagne = LTE to eHRPD fallback (Handover without signal and data loss, if modem is in RRC_CONNECTED state).
Host must control RAT transition by QMI SDK API.

If it’s not support, modem should get strongest RAT at boot-up time with following settings.
!SELRAT = 0 : Auto
!BAND=0 : Auto

This seems to be the only way.