MC7304 Voice Call Busy Tone

Hi

Have just received a voice enabled firmware for the MC7304 from our distributor (04.05.23.00). On first experimentation, voice call is only possible when I force the module to use ONLY GSM bands:

AT!BAND=05

If I leave the module open to ALL BANDS (AT!BAND=00) I simply receive a busy tone when I call the device. I have ensured using AT!SELMODE that both CS and PS service domains are active. Has anyone else had any experience of getting the device to accept/make CS voice calls when connected to the WCDMA network?

Thanks

Chris

Hi Chris,

Are you testing with live network?
And how about using !BAND=8 (WCDMA ALL)?

For my case, using MC7304 (FW 04.05.19.00) with live LTE network, setting !BAND=0.
On receiving voice call, it automatically fallback to WCDMA from LTE and ring, and I am able to answer the call.
On outgoing call, again, it fallbacks to WCDMA then remote party ring.

I am guessing network issue or your MC7304’s configuration cause the issue.
Is it possible for you to check with your local FAE/distribator to see if any specific setting required for the network you used?

Thx

2lotam:

Could you suggest any voice dialing software that works with MC7304?
For now, I have found nothing compatible, unfortunately.
I think there must be some version of Watcher (or Skylight:)) that supports dialpad and MC7304 simultaneously, right?

Hi lotam

I am using the live network, using a vodafone 3G sim. Current status is:
-> When forced to GSM (!BAND=5) I can make calls from the module. Cannot receive any calls.
-> When allowed into any band, no calls can be made/recieved (all fail with NO CARRIER)

I have also been able to test with an EE 4G SIM:
-> When on LTE network and make a call from MC7304, correctly fall-back to WCDMA but call fails with NO CARRIER.
-> When on WCDMA network, no calls can be made/received (NO CARRIER)
-> When on GSM network, no calls can be made/received (NO CARRIER)
-> Have tested the SIM in a normal handset and can make/receive all calls

Could it be configuration? Is there a factory reset command? Have tried AT!RMARESET but gives ERROR.

Thanks

Hi vve,

Sorry, I am not aware of software for voice dialing.
I use mainly AT command. Maybe you can build on based on QMI or AT cmd?

Hi Chris,

Appears to be network issue or module configuration?
At least using Vodafone SIM in 2G mode, you are able to make call but not with EE sim.

Do you have chance to discuss with your local FAE/distributor? Probably they will know more the local network requirement and may further investigate by taking FW log?

Thx.

Hi Lotam

I’m not sure, using the Voadfone 3G SIM in an Option GTM609W module allows calls to be made AND received in both WCDMA_ONLY and GSM modes. Suggests to me that it is a module configuration issue. Not sure why the EE SIM dosen’t work at all…

What AT commands do you issue to dial? ATD01483… for example?

I have notified our local FAE, waiting on a reply from them. I wonder if its FW issue, is there any possibility of someone testing on our FW version (04.05.23.00)?

Many thanks

Chris

Hi

Little bump. Lotam, is it possible for someone at Sierra to test the MC7304 calling functionality with the 04.05.23.00 firmware? Still at no solution and it seems it isn’t a clear network problem as the Option GTM609W module can receive and send calls using the same SIM.

An additional factor to add is that SMS sending is hanging the QMI SDK? Can recieve messages fine but sending using the SMS Sample Application causes the SDK to hang (using SDK 03_02_03)

Chris

SMS now working, was that the SMS centre number had not been set in the sample SMS application.

Any news on Voice firmware testing?

Thanks

Chris

Hi

I’ve attached 4 log files (1 in a separate post due to limits). They show QXDM logs for attempted outgoing and incoming calls to the MC7304 device.

One concerning point is that the outgoing calls appear to be being sent to the network as CSD instead of CSV (circuit switched voice). Incoming calls are being rejected with the following error:

MT – mobile aborted before call connected
OutgoingCallGSM.txt (72.5 KB)
IncomingCallWCMDA.txt (14.1 KB)
IncomingCallGSM.txt (9.38 KB)

Last log file…
OutgoingCallWCDMA.txt (16.1 KB)

It seems to be that, when attempting a voice call specifically using the

ATD;

command, the module aborts the call. The reason that the GSM outgoing call works is that I was issuing a CSD dial command (without the semicolon) :

ATD<phonenumber >

Seems to suggest, that something isn’t configured correctly to allow voice call dialling and receiving but CSD is fine.

Chris

Hi Lotam

Still no joy on this. Has anyone at Sierra had a chance to look at the logs I provided? Specifically the incoming calls…which show the CS voice call failing after the network has paged the device with incoming call requests.

Chris

Hi Chris,

Does issue solved?
Do you have chance to discuss with your local FAE/distributor?

Thx

Problem fixed with help from Lotam and FAE distributor. An NV item on the device had been miss-set at the factory. AT!NV?5280 now reads: 00 00 00 00 00 00 00 00 and all CS voice calls appear to connect.

Now to test PCM functionality.

Many thanks to all for the help

It seems that I have the same Problem as Chris.

Is anybody here who can tell me what to do to fix this problem?

Thanks in advance.

Can you please help me how to take logs from DM port of MC7304

With Regards
P S Reddy